The Keysight InfiniiVision 1000 X-Series oscilloscopes deliver these features:

- 7 inch WVGA display.

### Table 1  
1000 X-Series Model Numbers, Bandwidths

<table>
<thead>
<tr>
<th>Model:</th>
<th>EDUX1002A</th>
<th>EDUX1002G</th>
<th>DSOX1102A</th>
<th>DSOX1102G</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channels:</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bandwidth:</td>
<td>50 MHz</td>
<td></td>
<td>70 MHz, 100 MHz with DSOX1B7T102 upgrade</td>
<td></td>
</tr>
<tr>
<td>Sampling rate:</td>
<td>1 GSa/s</td>
<td></td>
<td>2 GSa/s</td>
<td></td>
</tr>
<tr>
<td>Memory:</td>
<td>100 kpts</td>
<td></td>
<td>1 Mpts</td>
<td></td>
</tr>
<tr>
<td>Segmented memory:</td>
<td>No</td>
<td></td>
<td>Yes</td>
<td></td>
</tr>
<tr>
<td>Waveform generator:</td>
<td>No</td>
<td>Yes (20 MHz)</td>
<td>No</td>
<td>Yes (20 MHz)</td>
</tr>
<tr>
<td>Mask/limit test:</td>
<td>No</td>
<td></td>
<td>Yes</td>
<td></td>
</tr>
</tbody>
</table>
- 50,000 waveforms/second update rate.
- All knobs are pushable for making quick selections.
- Trigger types: edge, pulse width, and video on EDUX1000-Series models. DSOX1000-Series models add: pattern, rise/fall time, and setup and hold.
- Serial decode/trigger options for: I2C and UART/RS232 on EDUX1000-Series models. DSOX1000-Series models add: CAN, LIN, and SPI.
- Math waveforms: add, subtract, multiply, divide, FFT (magnitude and phase), and low-pass filter.
- Reference waveforms (2) for comparing with other channel or math waveforms.
- Many built-in measurements.
- G-suffix models have built-in waveform generator with: sine, square, ramp, pulse, DC, noise.
- USB port makes printing, saving, and sharing data easy.
- A Quick Help system is built into the oscilloscope. Press and hold any key to display Quick Help. Complete instructions for using the quick help system are given in "Access the Built-In Quick Help" on page 29.

For more information about InfiniiVision oscilloscopes, see:
www.keysight.com/find/scope
In This Guide

This guide shows how to use the InfiniiVision 1000 X-Series oscilloscopes.

<table>
<thead>
<tr>
<th>When unpacking and using the oscilloscope for the first time, see:</th>
<th>Chapter 1, “Getting Started,” starting on page 11</th>
</tr>
</thead>
</table>
| When displaying waveforms and acquired data, see: | “Running, Stopping, and Making Single Acquisitions (Run Control)” on page 32  
“Horizontal Controls” on page 33  
“Vertical Controls” on page 36  
“FFT Spectral Analysis” on page 40  
“Math Waveforms” on page 44  
“Reference Waveforms” on page 46  
“Display Settings” on page 47 |
| When setting up triggers or changing how data is acquired, see: | “Triggers” on page 50  
“Acquisition Control” on page 54 |
| Making measurements and analyzing data: | “Cursors” on page 61  
“Measurements” on page 63  
“Mask Testing” on page 65  
“Digital Voltmeter” on page 72  
“Frequency Response Analysis” on page 73 |
| When using the built-in waveform generator, see: | “Waveform Generator” on page 75 |
| When using licensed serial bus decode and triggering features, see: | “Serial Bus Decode/Trigger” on page 76 |
| When saving, recalling, or printing, see: | “Save/Recall (Setups, Screens, Data)” on page 82  
“Print (Screens)” on page 85 |
When using the oscilloscope's utility functions, see:

- "Utility Settings" on page 86

For reference information, see:

- "Specifications and Characteristics" on page 89
- "Environmental Conditions" on page 90
- "Probes and Accessories" on page 91
- "Software and Firmware Updates" on page 92
- "Acknowledgements" on page 93

**NOTE**

Abbreviated instructions for pressing a series of keys and softkeys

Instructions for pressing a series of keys are written in an abbreviated manner. Instructions for pressing [Key1], then pressing Softkey2, then pressing Softkey3 are abbreviated as follows:

Press [Key1] > Softkey2 > Softkey3.

The keys may be a front panel [Key] or a Softkey. Softkeys are the six keys located directly below the oscilloscope display.
Contents

InfiniiVision 1000 X-Series Oscilloscopes—At a Glance / 3
In This Guide / 5

1  Getting Started

Inspect the Package Contents / 12
Power-On the Oscilloscope / 13
Connect Probes to the Oscilloscope / 14

⚠️
Maximum input voltage at analog inputs / 14
⚠️
Do not float the oscilloscope chassis / 14

Input a Waveform / 15
Recall the Default Oscilloscope Setup / 16
Use Autoscale / 17
Compensate Passive Probes / 18
Learn the Front Panel Controls and Connectors / 20
   Front Panel Overlays for Different Languages / 25
Learn the Rear Panel Connectors / 26
Learn the Oscilloscope Display / 27
Access the Built-In Quick Help / 29

2  Quick Reference

Running, Stopping, and Making Single Acquisitions (Run Control) / 32
Horizontal Controls / 33
  Horizontal Knobs and Keys / 33
  Horizontal Softkey Controls / 33
  Zoom / 34

Vertical Controls / 36
  Vertical Knobs and Keys / 36
  Vertical Softkey Controls / 36
  Setting Analog Channel Probe Options / 38

Analog Bus Display / 39

FFT Spectral Analysis / 40
  FFT Measurement Hints / 40
  FFT DC Value / 42
  FFT Aliasing / 42
  FFT Spectral Leakage / 43

Math Waveforms / 44
  Units for Math Waveforms / 45

Reference Waveforms / 46

Display Settings / 47
  To load a list of labels from a text file you create / 48

Triggers / 50
  Trigger Knobs and Keys / 50
  Trigger Types / 50
  Trigger Mode, Coupling, Reject, Holdoff / 51
  External Trigger Input / 53

⚠️
  Maximum voltage at oscilloscope external trigger input / 53

Acquisition Control / 54
  Selecting the Acquisition Mode / 54
  Overview of Sampling / 55
<table>
<thead>
<tr>
<th>Feature</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursors / 61</td>
<td></td>
</tr>
<tr>
<td>Cursor Knobs and Keys / 61</td>
<td></td>
</tr>
<tr>
<td>Cursor Softkey Controls / 61</td>
<td></td>
</tr>
<tr>
<td>Measurements / 63</td>
<td></td>
</tr>
<tr>
<td>Mask Testing / 65</td>
<td></td>
</tr>
<tr>
<td>Creating/Editing Mask Files / 65</td>
<td></td>
</tr>
<tr>
<td>Digital Voltmeter / 72</td>
<td></td>
</tr>
<tr>
<td>Frequency Response Analysis / 73</td>
<td></td>
</tr>
<tr>
<td>Waveform Generator / 75</td>
<td></td>
</tr>
<tr>
<td>Serial Bus Decode/Trigger / 76</td>
<td></td>
</tr>
<tr>
<td>CAN Decode/Trigger / 77</td>
<td></td>
</tr>
<tr>
<td>I2C Decode/Trigger / 78</td>
<td></td>
</tr>
<tr>
<td>LIN Decode/Trigger / 78</td>
<td></td>
</tr>
<tr>
<td>SPI Decode/Trigger / 79</td>
<td></td>
</tr>
<tr>
<td>UART/RS232 Decode/Trigger / 80</td>
<td></td>
</tr>
<tr>
<td>Save/Recall (Setups, Screens, Data) / 82</td>
<td></td>
</tr>
<tr>
<td>Length Control / 83</td>
<td></td>
</tr>
<tr>
<td>Print (Screens) / 85</td>
<td></td>
</tr>
<tr>
<td>Utility Settings / 86</td>
<td></td>
</tr>
<tr>
<td>USB Storage Devices / 87</td>
<td></td>
</tr>
<tr>
<td>Configuring the [Quick Action] Key / 88</td>
<td></td>
</tr>
<tr>
<td>Specifications and Characteristics / 89</td>
<td></td>
</tr>
<tr>
<td>Environmental Conditions / 90</td>
<td></td>
</tr>
<tr>
<td>Declaration of Conformity / 90</td>
<td></td>
</tr>
<tr>
<td>Probes and Accessories / 91</td>
<td></td>
</tr>
<tr>
<td>Software and Firmware Updates / 92</td>
<td></td>
</tr>
<tr>
<td>Acknowledgements / 93</td>
<td></td>
</tr>
</tbody>
</table>
1 Getting Started

Inspect the Package Contents / 12
Power-On the Oscilloscope / 13
Connect Probes to the Oscilloscope / 14
Input a Waveform / 15
Recall the Default Oscilloscope Setup / 16
Use Autoscale / 17
Compensate Passive Probes / 18
Learn the Front Panel Controls and Connectors / 20
Learn the Rear Panel Connectors / 26
Learn the Oscilloscope Display / 27
Access the Built-In Quick Help / 29

This chapter describes the steps you take when using the oscilloscope for the first time.
Inspect the Package Contents

- Inspect the shipping container for damage.
  
  If your shipping container appears to be damaged, keep the shipping container or cushioning material until you have inspected the contents of the shipment for completeness and have checked the oscilloscope mechanically and electrically.

- Verify that you received the following items and any optional accessories you may have ordered:
  - InfiniiVision 1000 X-Series oscilloscope.
  - Power cord (country of origin determines specific type).
  - Two oscilloscope probes.
Power-On the Oscilloscope

**Power Requirements**
Line voltage, frequency, and power:
- ~Line 100-120 Vac, 50/60/400 Hz
- 100-240 Vac, 50/60 Hz
- 50 W max

**Ventilation Requirements**
The air intake and exhaust areas must be free from obstructions. Unrestricted airflow is required for proper cooling. Always ensure that the air intake and exhaust areas are free from obstructions.

The fan draws air in from the left side and bottom of the oscilloscope and pushes it out behind the oscilloscope.

When using the oscilloscope in a bench-top setting, provide at least 2" clearance at the sides and 4" (100 mm) clearance above and behind the oscilloscope for proper cooling.

**To power-on the oscilloscope**

1. Connect the power cord to the rear of the oscilloscope, then to a suitable AC voltage source. Route the power cord so the oscilloscope's feet and legs do not pinch the cord.
2. The oscilloscope automatically adjusts for input line voltages in the range 100 to 240 VAC. The line cord provided is matched to the country of origin.

**WARNING**
Always use a grounded power cord. Do not defeat the power cord ground.

3. Press the power switch.

The power switch is located on the lower left corner of the front panel. The oscilloscope will perform a self-test and will be operational in a few seconds.
Connect Probes to the Oscilloscope

1. Connect the oscilloscope probe to an oscilloscope channel BNC connector.
2. Connect the probe's retractable hook tip to the point of interest on the circuit or device under test. Be sure to connect the probe ground lead to a ground point on the circuit.

**CAUTION**

⚠️ Maximum input voltage at analog inputs
150 Vrms, 200 Vpk

**CAUTION**

⚠️ Do not float the oscilloscope chassis
Deeating the ground connection and "floating" the oscilloscope chassis will probably result in inaccurate measurements and may also cause equipment damage. The probe ground lead is connected to the oscilloscope chassis and the ground wire in the power cord. If you need to measure between two live points, use a differential probe with sufficient dynamic range.

**WARNING**

⚠️ Do not negate the protective action of the ground connection to the oscilloscope. The oscilloscope must remain grounded through its power cord. Defeating the ground creates an electric shock hazard.
Input a Waveform

The Probe Comp signal is used for compensating probes.

1. Connect an oscilloscope probe from channel 1 to the Demo, Probe Comp terminal on the front panel.

2. Connect the probe’s ground lead to the ground terminal (next to the Demo terminal).
Recall the Default Oscilloscope Setup

To recall the default oscilloscope setup:

1. Press [Default Setup].

The default setup restores the oscilloscope’s default settings. This places the oscilloscope in a known operating condition.

In the Save/Recall menu, there are also options for restoring the complete factory settings or performing a secure erase (see "Save/Recall (Setups, Screens, Data)" on page 82).
Use Autoscale

Use [Auto Scale] to automatically configure the oscilloscope to best display the input signals.

1. Press [Auto Scale].
   
   You should see a waveform on the oscilloscope's display similar to this:

   ![Waveform Image]

2. If you want to return to the oscilloscope settings that existed before, press Undo Autoscale.

3. If you want to enable "fast debug" autoscaling, change the channels autoscaled, or preserve the acquisition mode during autoscale, press Fast Debug, Channels, or Acq Mode.
   
   These are the same softkeys that appear in the Autoscale Preferences menu. See "Utility Settings" on page 86.

   If you see the waveform, but the square wave is not shaped correctly as shown above, perform the procedure "Compensate Passive Probes" on page 18.

   If you do not see the waveform, make sure the probe is connected securely to the front panel channel input BNC and to the Demo/Probe Comp terminal.
Compensate Passive Probes

Each oscilloscope passive probe must be compensated to match the input characteristics of the oscilloscope channel to which it is connected. A poorly compensated probe can introduce significant measurement errors.

**NOTE**

If your probe has a configurable attenuation setting (like the N2140/42A probes do), the 10:1 setting must be used for probe compensation.

1. Input the Probe Comp signal (see "Input a Waveform" on page 15).
2. Press [Default Setup] to recall the default oscilloscope setup (see "Recall the Default Oscilloscope Setup" on page 16).
3. Press [Auto Scale] to automatically configure the oscilloscope for the Probe Comp signal (see "Use Autoscale" on page 17).
4. Press the channel key to which the probe is connected ([1], [2], etc.).
5. In the Channel Menu, press **Probe**.
6. In the Channel Probe Menu, press **Probe Check**; then, follow the instructions on-screen.

   If necessary, use a nonmetallic tool (supplied with the probe) to adjust the trimmer capacitor on the probe for the flattest pulse possible.

   On some probes (like the N2140/42A probes), the trimmer capacitor is located on the probe BNC connector. On other probes (like the N2862/63/90 probes), the trimmer capacitor is a yellow adjustment on the probe tip.

   ![Waveform Examples]

   **Perfectly compensated**

   **Over compensated**

   **Under compensated**

7. Connect probes to all other oscilloscope channels.
Repeat the procedure for each channel.
Learn the Front Panel Controls and Connectors

On the front panel, key refers to any key (button) you can press.

Softkey specifically refers to the six keys next to the display. Menus and softkey labels appear on the display when other front panel keys are pressed. Softkey functions change as you navigate through the oscilloscope’s menus.

For the following figure, refer to the numbered descriptions in the table that follows.

---

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Softkeys</td>
<td>The functions of these keys change based upon the menus shown on the display next to the keys. The Back key moves back in the softkey menu hierarchy. At the top of the hierarchy, the Back key turns the menus off, and oscilloscope information is shown instead.</td>
</tr>
<tr>
<td>3. [Intensity] key</td>
<td>Press the key to illuminate it. When illuminated, turn the Entry knob to adjust waveform intensity. You can vary the intensity control to bring out signal detail, much like an analog oscilloscope.</td>
</tr>
<tr>
<td>4.</td>
<td>Entry knob</td>
</tr>
<tr>
<td>-----</td>
<td>------------</td>
</tr>
<tr>
<td>5.</td>
<td>[Default Setup] key</td>
</tr>
<tr>
<td>6.</td>
<td>[Auto Scale] key</td>
</tr>
<tr>
<td>7.</td>
<td>Horizontal and Acquisition controls</td>
</tr>
<tr>
<td></td>
<td>– Horizontal scale knob – Turn the knob in the Horizontal section that is marked to adjust the time/div setting. The symbols under the knob indicate that this control has the effect of spreading out or zooming in on the waveform using the horizontal scale. Push the horizontal scale knob to toggle between fine and coarse adjustment.</td>
</tr>
<tr>
<td></td>
<td>– Horizontal position knob – Turn the knob marked to pan through the waveform data horizontally. You can see the captured waveform before the trigger (turn the knob clockwise) or after the trigger (turn the knob counterclockwise). If you pan through the waveform when the oscilloscope is stopped (not in Run mode) then you are looking at the waveform data from the last acquisition taken.</td>
</tr>
<tr>
<td></td>
<td>– [Acquire] key – Press this key to open the Acquire menu where you can select the Normal, XY, and Roll time modes, enable or disable Zoom, and select the trigger time reference point. Also you can select the Normal, Peak Detect, Averaging, or High Resolution acquisition modes and, on DSOX1000-Series models, use segmented memory (see “Selecting the Acquisition Mode” on page 54).</td>
</tr>
<tr>
<td></td>
<td>– Zoom key – Press the zoom key to split the oscilloscope display into Normal and Zoom sections without opening the Acquire menu. For more information see “Horizontal Controls” on page 33.</td>
</tr>
</tbody>
</table>
### Run Control keys

When the [Run/Stop] key is green, the oscilloscope is running, that is, acquiring data when trigger conditions are met. To stop acquiring data, press [Run/Stop].

When the [Run/Stop] key is red, data acquisition is stopped. To start acquiring data, press [Run/Stop].

To capture and display a single acquisition (whether the oscilloscope is running or stopped), press [Single]. The [Single] key is yellow until the oscilloscope triggers.

For more information, see “Running, Stopping, and Making Single Acquisitions (Run Control)” on page 32.

### Measure controls

The measure controls consist of:

- **[Analyze]** key — Press this key to access analysis features like trigger level setting, measurement threshold setting, Video trigger automatic set up and display, or digital voltmeter (see “Digital Voltmeter” on page 72).

- **[Meas]** key — Press this key to access a set of predefined measurements. See “Measurements” on page 63.

- **[Cursors]** key — Press this key to open a menu that lets you select the cursors mode and source.

- **Cursors knob** — Push this knob select cursors from a popup menu. Then, after the popup menu closes (either by timeout or by pushing the knob again), rotate the knob to adjust the selected cursor position.

### Tools keys

The Tools keys consist of:

- **[Save/Recall]** key — Press this key to save oscilloscope setups, screen images, waveform data, or mask files or to recall setups, mask files or reference waveforms. See “Save/Recall (Setups, Screens, Data)” on page 82.

- **[Utility]** key — Press this key to access the Utility menu, which lets you configure the oscilloscope’s I/O settings, use the file explorer, set preferences, access the service menu, and choose other options. See “Utility Settings” on page 86.

- **[Display]** key — Press this key to access the menu where you can enable persistence, adjust the display grid (graticule) intensity, label waveforms, add an annotation, and clear the display (see “Display Settings” on page 47).

- **[Quick Action]** key — Press this key to perform the selected quick action: measure all snapshot, print, save, recall, freeze display, and more. See “Configuring the [Quick Action] Key” on page 88.

- **[Save to USB]** key — Press this key to perform a quick save to a USB storage device.
### 11. Trigger controls

The Trigger controls determine how the oscilloscope triggers to capture data. These controls consist of:
- **Level knob** — Turn the Level knob to adjust the trigger level for a selected analog channel. Push the knob to set the level to the waveform's 50% value. If AC coupling is used, pushing the Level knob sets the trigger level to about 0 V.

The position of the trigger level for the analog channel is indicated by the trigger level icon (if the analog channel is on) at the far left side of the display. The value of the analog channel trigger level is displayed in the upper-right corner of the display.
- **[Trig]** key — Press this key to select the trigger type (edge, pulse width, video, etc.). See "Trigger Types" on page 50. You can also set options that affect all trigger types. See "Trigger Mode, Coupling, Reject, Holdoff" on page 51.
- **[Force]** key — Causes a trigger (on anything) and displays the acquisition. This key is useful in the Normal trigger mode where acquisitions are made only when the trigger condition is met. In this mode, if no triggers are occurring (that is, the "Trig'd?" indicator is displayed), you can press [Force] to force a trigger and see what the input signals look like.
- **[External]** key — Press this key to set external trigger input options. See "External Trigger Input" on page 53.

### 12. Waveform keys

The additional waveform controls consist of:
- **[FFT]** key — provides access to FFT spectrum analysis function. See "FFT Spectral Analysis" on page 40.
- **[Math]** key — provides access to math (add, subtract, etc.) waveform functions. See "Math Waveforms" on page 44.
- **[Ref]** key — provides access to reference waveform functions. Reference waveforms are saved waveforms that can be displayed and compared against other analog channel or math waveforms. See "Reference Waveforms" on page 46.
- **[Wave Gen]** key — On G-suffix models that have a built-in waveform generator, press this key to access waveform generator functions. See "Waveform Generator" on page 75.

### 13. [Help] key

Opens the Help menu where you can display overview help topics and select the Language. See also "Access the Built-In Quick Help" on page 29.

### 14. [Bus] key

Opens the Bus menu where you can:
- Display a bus made up of the analog channel inputs and the external trigger input where channel 1 is the least significant bit and the external trigger input is the most significant bit. See also "Analog Bus Display" on page 39.
- Enable serial bus decodes. See also "Serial Bus Decode/Trigger" on page 76.

### 15. Ext Trig input

External trigger input BNC connector. See "External Trigger Input" on page 53 for an explanation of this feature.
### Vertical controls

The Vertical controls consist of:

- **Analog channel on/off keys** — Use these keys to switch a channel on or off, or to access a channel's menu in the softkeys. There is one channel on/off key for each analog channel.

- **Vertical scale knob** — There are knobs marked \( \wedge, \vee \) for each channel. Use these knobs to change the vertical sensitivity (gain) of each analog channel. Push the channel's vertical scale knob to toggle between fine and coarse adjustment. The default mode for expanding the signal is about the ground level of the channel; however, you can change this to expand about the center of the display.

- **Vertical position knobs** — Use these knobs to change a channel's vertical position on the display. There is one Vertical Position control for each analog channel. The voltage value momentarily displayed in the upper right portion of the display represents the voltage difference between the vertical center of the display and the ground level (\( \wedge, \vee \) icon). It also represents the voltage at the vertical center of the display if vertical expansion is set to expand about ground. For more information, see “Vertical Controls” on page 36.

### Analog channel inputs

Attach oscilloscope probes or BNC cables to these BNC connectors. In the InfiniiVision 1000 X-Series oscilloscopes, the analog channel inputs have 1 \( \text{M} \Omega \) impedance. Also, there is no automatic probe detection, so you must properly set the probe attenuation for accurate measurement results. See “Setting Analog Channel Probe Options” on page 38.

### Waveform generator output

On G-suffix models, the built-in waveform generator can output sine, square, ramp, pulse, DC, or noise on the Gen Out BNC. Press the [Wave Gen] key to set up the waveform generator. See “Waveform Generator” on page 75. You can also send the trigger output signal or the mask test failure signal to the Gen Out BNC connector. See “Utility Settings” on page 86.

### Demo/Probe Comp, Ground terminals

- **Demo terminal** — This terminal outputs the Probe Comp signal which helps you match a probe’s input capacitance to the oscilloscope channel to which it is connected. See “Compensate Passive Probes” on page 18. With certain licensed features, the oscilloscope can also output demo or training signals on this terminal.

- **Ground terminal** — Use the ground terminal for oscilloscope probes connected to the Demo/Probe Comp terminal.
Front Panel Overlays for Different Languages

Front panel overlays, which have translations for the English front panel keys and label text, are available in many languages. The appropriate overlay is included when the localization option is chosen at time of purchase.

To install a front panel overlay:
1. Gently pull on the front panel knobs to remove them.
2. Insert the overlay’s side tabs into the slots on the front panel.
3. Reinstall the front panel knobs.

CAUTION: Do not connect a host computer to the oscilloscope's USB host port. A host computer sees the oscilloscope as a device, so connect the host computer to the oscilloscope's device port (on the rear panel). See "Learn the Rear Panel Connectors" on page 26.
Learn the Rear Panel Connectors

For the following figure, refer to the numbered descriptions in the table that follows.

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Power cord connector</td>
<td>Attach the power cord here.</td>
</tr>
<tr>
<td>2</td>
<td>Kensington lock hole</td>
<td>This is where you can attach a Kensington lock for securing the instrument.</td>
</tr>
<tr>
<td>3</td>
<td>USB Device port</td>
<td>This port is for connecting the oscilloscope to a host PC. You can issue remote commands from a host PC to the oscilloscope via the USB device port.</td>
</tr>
</tbody>
</table>
Learn the Oscilloscope Display

The oscilloscope display contains acquired waveforms, setup information, measurement results, and the softkey definitions.

![Oscilloscope Display Diagram]

**Figure 1** Interpreting the oscilloscope display

<table>
<thead>
<tr>
<th>Status line</th>
<th>The top line of the display contains vertical, horizontal, and trigger setup information.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display area</td>
<td>The display area contains the waveform acquisitions, channel identifiers, and analog trigger, and ground level indicators. Each analog channel's information appears in a different color. Signal detail is displayed using 256 levels of intensity. For more information about display modes see &quot;Display Settings&quot; on page 47.</td>
</tr>
</tbody>
</table>
## Getting Started

### Softkey labels and information area

When most front panel keys are pressed, short menu names and softkey labels appear in this area. The labels describe the softkey functions. Typically, softkeys let you set up additional parameters for the selected mode or menu.

Pressing the Back key returns through the menu hierarchy until softkey labels are off and the information area is displayed. The information area contains acquisition, analog channel, math function, and reference waveform information.

You can also specify that softkey menus turn off automatically after a specified timeout period ([Utility] > Options > Menu Timeout).

Pressing the Back key when the information area is displayed returns to the most recent menu displayed.

<table>
<thead>
<tr>
<th>Measurements area</th>
</tr>
</thead>
<tbody>
<tr>
<td>When measurements or cursors are turned on, this area contains automatic measurement and cursor results.</td>
</tr>
<tr>
<td>When measurements are turned off, this area displays additional status information describing channel offset and other configuration parameters.</td>
</tr>
</tbody>
</table>
Access the Built-In Quick Help

To view Quick Help

Press and hold the key, softkey, or knob for which you would like to view help. Quick Help remains on the screen until another key is pressed or a knob is turned.

To select the user interface and Quick Help language:

1. Press [Help], then press the Language softkey.
2. Turn the Entry knob until the desired language is selected.
1  Getting Started
2 Quick Reference

Running, Stopping, and Making Single Acquisitions (Run Control) / 32
Horizontal Controls / 33
Vertical Controls / 36
Analog Bus Display / 39
FFT Spectral Analysis / 40
Math Waveforms / 44
Reference Waveforms / 46
Display Settings / 47
Triggers / 50
Acquisition Control / 54
Cursors / 61
Measurements / 63
Mask Testing / 65
Digital Voltmeter / 72
Waveform Generator / 75
Serial Bus Decode/Trigger / 76
Save/Recall (Setups, Screens, Data) / 82
Print (Screens) / 85
Utility Settings / 86
Specifications and Characteristics / 89
Environmental Conditions / 90
Probes and Accessories / 91
Software and Firmware Updates / 92
Acknowledgements / 93
Running, Stopping, and Making Single Acquisitions (Run Control)

To display the results of multiple acquisitions, use persistence. See "Display Settings" on page 47.

**Single vs. Running and Record Length**

The maximum data record length is greater for a single acquisition than when the oscilloscope is running (or when the oscilloscope is stopped after running):

- **Single** — Single acquisitions always use the maximum memory available — at least twice as much memory as acquisitions captured when running — and the oscilloscope stores at least twice as many samples. At slower time/div settings, because there is more memory available for a single acquisition, the acquisition has a higher effective sample rate.

- **Running** — When running (versus taking a single acquisition), the memory is divided in half. This lets the acquisition system acquire one record while processing the previous acquisition, dramatically improving the number of waveforms per second processed by the oscilloscope. When running, a high waveform update rate provides the best representation of your input signal.

To acquire data with the longest possible record length, press the [Single] key.

For more information on settings that affect record length, see "Length Control" on page 83.

**Table 2 Run Control Features**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run acquisitions</td>
<td>[Run/Stop] (the key is green when running)</td>
</tr>
<tr>
<td>Stop acquisitions</td>
<td>[Run/Stop] (the key is red when stopped)</td>
</tr>
<tr>
<td>Single acquisition</td>
<td>[Single] (the key is yellow until the oscilloscope triggers) If the oscilloscope does not trigger, you can press [Force Trigger] to trigger on anything and make a single acquisition.</td>
</tr>
</tbody>
</table>
Horizontal Controls

Horizontal Knobs and Keys

Horizontal Softkey Controls

The following figure shows the Acquire menu which appears after pressing the [Acquire] key.
The time reference is indicated at the top of the display grid by a small hollow triangle (∇). Turning the Horizontal scale knob expands or contracts the waveform about the time reference point (∇).

The trigger point, which is always time = 0, is indicated at the top of the display grid by a small solid triangle (▼).

The delay time is the time of the reference point with respect to the trigger. Turning the Horizontal position ((GUI) knob moves the trigger point (▼) to the left or right of the time reference (∇) and displays the delay time.

The Acquire menu lets you select the time mode (Normal, XY, or Roll), enable Zoom, set the time base fine control (vernier), and specify the time reference.

### Table 3  Horizontal Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time mode</td>
<td>[Acquire] &gt; Time Mode (Normal, XY, or Roll)</td>
</tr>
<tr>
<td>XY time mode</td>
<td>[Acquire] &gt; Time Mode, XY</td>
</tr>
<tr>
<td></td>
<td>Channel 1 is the X-axis input, channel 2 is the Y-axis input. The Z-axis input (Ext Trig) turns the trace on and off (blanking). When Z is low (&lt;1.4 V), Y versus X is displayed; when Z is high (&gt;1.4 V), the trace is turned off. Measuring the phase difference between two signals of the same frequency with the Lissajous method is a common use of the XY display mode (see the &quot;XY Display Mode Example&quot; description at <a href="http://www.keysight.com/find/xy-display-mode">www.keysight.com/find/xy-display-mode</a>).</td>
</tr>
<tr>
<td>Roll time mode</td>
<td>[Acquire] &gt; Time Mode, Roll</td>
</tr>
<tr>
<td>Zoom</td>
<td>[Acquire] &gt; Zoom (or press the zoom key)</td>
</tr>
<tr>
<td>Time reference</td>
<td>[Acquire] &gt; Time Ref (Left, Center, Right)</td>
</tr>
</tbody>
</table>

See Also  "Acquisition Control" on page 54

### Zoom

The Zoom window is a magnified portion of the normal time/div window. To turn on (or off) Zoom, press the zoom key (or press the [Acquire] key and then the Zoom softkey).
These markers show the beginning and end of the Zoom window.

Time/div for zoomed window

Time/div for normal window

Delay time momentarily displays when the Horizontal position knob is turned.

Select Zoom

Normal window

Signal anomaly expanded in zoom window
Vertical Controls

Vertical Knobs and Keys

NOTE Keysight recommends always scaling the signal so that the entire waveform is contained between the top and bottom of the display.

For proper operation of the 1000 X-Series oscilloscope, the channel inputs must not be overdriven more than ±8 divisions. Exceeding this limit may result in signals that appear incorrect and may increase crosstalk between the input channels.

NOTE To minimize crosstalk between input channels, make sure the channel is not overdriven. Also, connecting a probe or cable to a channel will reduce crosstalk.

Vertical Softkey Controls

The following figure shows the Channel 1 menu that appears after pressing the [1] channel key.
The ground level of the signal for each displayed analog channel is identified by the position of the ground icon at the far-left side of the display.

Table 4  Vertical Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel coupling</td>
<td>[1/2] &gt; Coupling (DC or AC)</td>
</tr>
<tr>
<td></td>
<td>Note that Channel Coupling is independent of Trigger Coupling. To change trigger coupling see “Trigger Mode, Coupling, Reject, Holdoff” on page 51.</td>
</tr>
<tr>
<td>Channel bandwidth limit</td>
<td>[1/2] &gt; BW Limit</td>
</tr>
<tr>
<td>Vertical scale fine adjustment</td>
<td>[1/2] &gt; Fine</td>
</tr>
<tr>
<td>Channel Invert</td>
<td>[1/2] &gt; Invert</td>
</tr>
</tbody>
</table>
Setting Analog Channel Probe Options

In the Channel menu, the **Probe** softkey opens the Channel Probe menu. This menu lets you select additional probe parameters such as attenuation factor and units of measurement for the connected probe.

**CAUTION**

For correct measurements, you must match the oscilloscope's probe attenuation factor settings with the attenuation factors of the probes being used.

### Table 5  Probe Features

<table>
<thead>
<tr>
<th>Channel Probe Menu</th>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Channel units</td>
<td>[1/2] &gt; Probe &gt; Units (Volts, Amps)</td>
</tr>
<tr>
<td>Probe attenuation</td>
<td>[1/2] &gt;Probe &gt; Probe, Ratio/Decibels, Entry knob</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Changes the vertical scale so that measurement results reflect the actual voltage levels at the probe tip.</td>
<td></td>
</tr>
<tr>
<td>Channel skew</td>
<td>[1/2] &gt; Probe &gt; Skew, Entry knob</td>
<td></td>
</tr>
<tr>
<td>Probe check</td>
<td>[1/2] &gt; Probe &gt; Probe Check</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Guides you through the process of compensating passive probes (such as the N2140A, N2142A, N2862A/B, N2863A/B, N2889A, N2890A, 10073C, 10074C, or 1165A probes).</td>
<td></td>
</tr>
</tbody>
</table>
Analog Bus Display

You can display a bus made up of the analog channel inputs and the external trigger input. Any of the input channels can be assigned to the bus. The bus values display appears at the bottom of the graticule. Channel 1 is the least significant bit and the external trigger input is the most significant bit.

Table 6  Analog Bus Display Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analog bus, display</td>
<td>[Bus] &gt; Display</td>
</tr>
<tr>
<td></td>
<td>[Bus] &gt; Select, ( \bigcirc ) Entry knob to select Analog Bus, push Select softkey or Entry knob to enable or disable</td>
</tr>
<tr>
<td>Analog bus, channel assignment</td>
<td>[Bus] &gt; Channel, ( \bigcirc ) Entry knob, push Entry knob to make or clear assignment</td>
</tr>
<tr>
<td>Analog bus, value number base</td>
<td>[Bus] &gt; Base, ( \bigcirc ) Entry knob (Hex, Binary)</td>
</tr>
<tr>
<td>Analog bus, channel 1 threshold level</td>
<td>[Bus] &gt; Ch1 Threshold, ( \bigcirc ) Entry knob, push Entry knob for 0 V</td>
</tr>
<tr>
<td>Analog bus, channel 2 threshold level</td>
<td>[Bus] &gt; Ch2 Threshold, ( \bigcirc ) Entry knob, push Entry knob for 0 V</td>
</tr>
<tr>
<td>Analog bus, external trigger input threshold level</td>
<td>[Bus] &gt; Ext Threshold, ( \bigcirc ) Entry knob, push Entry knob for 0 V</td>
</tr>
</tbody>
</table>
FFT Spectral Analysis

FFT is used to compute the fast Fourier transform using analog input channels. FFT takes the digitized time record of the specified source and transforms it to the frequency domain.

When the FFT function is selected, the FFT spectrum is plotted on the oscilloscope display as magnitude in dBV versus frequency. The readout for the horizontal axis changes from time to frequency (Hertz) and the vertical readout changes from volts to dB.

Use the FFT function to find crosstalk problems, to find distortion problems in analog waveforms caused by amplifier non-linearity, or for adjusting analog filters.

Table 7  FFT Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>FFT span/center</td>
<td>[FFT] &gt; Span</td>
</tr>
<tr>
<td></td>
<td>[FFT] &gt; Center</td>
</tr>
<tr>
<td>FFT window</td>
<td>[FFT] &gt; Settings &gt; Window (Hanning, Flat Top, Rectangular, Blackman Harris, see also “FFT Spectral Leakage” on page 43)</td>
</tr>
<tr>
<td>FFT vertical units</td>
<td>[FFT] &gt; Settings &gt; Vertical Units (Decibels, VRMS)</td>
</tr>
<tr>
<td>FFT auto setup</td>
<td>[FFT] &gt; Settings &gt; Auto Setup</td>
</tr>
<tr>
<td>FFT waveform, scale</td>
<td>[FFT] &gt; Scale, Entry knob</td>
</tr>
<tr>
<td>FFT waveform, offset</td>
<td>[FFT] &gt; Offset, Entry knob</td>
</tr>
</tbody>
</table>

FFT Measurement Hints

The number of points acquired for the FFT record can be up to 65,536, and when frequency span is at maximum, all points are displayed. Once the FFT spectrum is displayed, the frequency span and center frequency controls are used much like the controls of a spectrum analyzer to examine the frequency of interest in greater detail. Place the desired part of the waveform at the center of the screen and decrease frequency span to increase the display resolution. As frequency span is decreased, the number of points shown is reduced, and the display is magnified.
While the FFT spectrum is displayed, use the [FFT] and [Cursors] keys to switch between measurement functions and frequency domain controls in FFT Menu.

**NOTE**

**FFT Resolution**

The FFT resolution is the quotient of the sampling rate and the number of FFT points (f_s/N). With a fixed number of FFT points (up to 65,536), the lower the sampling rate, the better the resolution.

Decreasing the effective sampling rate by selecting a greater time/div setting will increase the low frequency resolution of the FFT display and also increase the chance that an alias will be displayed. The resolution of the FFT is the effective sample rate divided by the number of points in the FFT. The actual resolution of the display will not be this fine as the shape of the window will be the actual limiting factor in the FFTs ability to resolve two closely space frequencies. A good way to test the ability of the FFT to resolve two closely spaced frequencies is to examine the sidebands of an amplitude modulated sine wave.

For the best vertical accuracy on peak measurements:

- Make sure the probe attenuation is set correctly. The probe attenuation is set from the Channel Menu if the operand is a channel.
- Set the source sensitivity so that the input signal is near full screen, but not clipped.
- Use the Flat Top window.
- Set the FFT sensitivity to a sensitive range, such as 2 dB/division.

For best frequency accuracy on peaks:

- Use the Hanning window.
- Use Cursors to place an X cursor on the frequency of interest.
- Adjust frequency span for better cursor placement.
- Return to the Cursors Menu to fine tune the X cursor.

FFT DC Value

The FFT computation produces a DC value that is incorrect. It does not take the offset at center screen into account. The DC value is not corrected in order to accurately represent frequency components near DC.

FFT Aliasing

When using FFTs, it is important to be aware of frequency aliasing. This requires that the operator have some knowledge as to what the frequency domain should contain, and also consider the sampling rate, frequency span, and oscilloscope vertical bandwidth when making FFT measurements. The FFT resolution (the quotient of the sampling rate and the number of FFT points) is displayed directly above the softkeys when the FFT Menu is displayed.

NOTE

Nyquist Frequency and Aliasing in the Frequency Domain

The Nyquist frequency is the highest frequency that any real-time digitizing oscilloscope can acquire without aliasing. This frequency is half of the sample rate. Frequencies above the Nyquist frequency will be under sampled, which causes aliasing. The Nyquist frequency is also called the folding frequency because aliased frequency components fold back from that frequency when viewing the frequency domain.

Aliasing happens when there are frequency components in the signal higher than half the sample rate. Because the FFT spectrum is limited by this frequency, any higher components are displayed at a lower (aliased) frequency.

The following figure illustrates aliasing. This is the spectrum of a 990 Hz square wave, which has many harmonics. The horizontal time/div setting for the square wave sets the sample rate and results in a FFT resolution of 1.91 Hz. The displayed FFT spectrum waveform shows the components of the input signal above the Nyquist frequency to be mirrored (aliased) on the display and reflected off the right edge.
Because the frequency span goes from $\approx 0$ to the Nyquist frequency, the best way to prevent aliasing is to make sure that the frequency span is greater than the frequencies of significant energy present in the input signal.

FFT Spectral Leakage

The FFT operation assumes that the time record repeats. Unless there is an integral number of cycles of the sampled waveform in the record, a discontinuity is created at the end of the record. This is referred to as leakage. In order to minimize spectral leakage, windows that approach zero smoothly at the beginning and end of the signal are employed as filters to the FFT. The FFT Menu provides four windows: Hanning, Flat Top, Rectangular, and Blackman-Harris. For more information on leakage, see Keysight Application Note 243, *The Fundamentals of Signal Analysis* at http://literature.cdn.keysight.com/litweb/pdf/5952-8898E.pdf.
Math Waveforms

Math functions can be performed on analog channels and lower math functions. The resulting math waveform is displayed in light purple.

Table 8  Math Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascaded math functions</td>
<td>[Math] &gt; Source</td>
</tr>
<tr>
<td>Math function waveforms, scale</td>
<td>[Math] &gt; Scale, .Entry knob</td>
</tr>
<tr>
<td>Math function waveforms, offset</td>
<td>[Math] &gt; Offset, .Entry knob</td>
</tr>
</tbody>
</table>

TIP  Math Operating Hints

If the analog channel or math function is clipped (not fully displayed on screen) the resulting displayed math function will also be clipped.

Once the function is displayed, the analog channel(s) may be turned off for better viewing of the math waveform.

The math function waveform can be measured using [Cursors] and/or [Meas].

Table 9  FFT (Magnitude), FFT (Phase) Operator Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto setup</td>
<td>[Math] &gt; Auto Setup</td>
</tr>
<tr>
<td>Span/center</td>
<td>[Math] &gt; More &gt; Span</td>
</tr>
<tr>
<td></td>
<td>[Math] &gt; More &gt; Center</td>
</tr>
<tr>
<td>Window function</td>
<td>[Math] &gt; More &gt; Window (Hanning, Flat Top, Rectangular, Blackman Harris, see also &quot;FFT Spectral Leakage&quot; on page 43)</td>
</tr>
</tbody>
</table>
Table 9  FFT (Magnitude), FFT (Phase) Operator Features (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical units</td>
<td>[Math] &gt; More &gt; Vertical Units (For FFT (Magnitude): Decibels or V RMS. For FFT (Phase): Radians or Degrees.)</td>
</tr>
<tr>
<td>FFT (Phase) zero phase reference point</td>
<td>[Math] &gt; More &gt; Zero Phase Ref (Trigger, Entire Display)</td>
</tr>
</tbody>
</table>

Table 10  Low Pass Filter Operator Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Math low-pass filter cutoff frequency</td>
<td>[Math] &gt; Band width</td>
</tr>
</tbody>
</table>

Units for Math Waveforms

Units for each input channel can be set to Volts or Amps using the Units softkey in the channel’s Probe Menu. Units for math function waveforms are:

<table>
<thead>
<tr>
<th>Math function</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>add or subtract</td>
<td>V or A</td>
</tr>
<tr>
<td>multiply</td>
<td>$V^2$, $A^2$, or W (Volt-Amp)</td>
</tr>
<tr>
<td>FFT Magnitude</td>
<td>dB (decibels) or V RMS.</td>
</tr>
<tr>
<td>FFT Phase</td>
<td>degrees or radians</td>
</tr>
</tbody>
</table>

A scale unit of U (undefined) will be displayed for math functions when two source channels are used and they are set to dissimilar units and the combination of units cannot be resolved.
Reference Waveforms

Analog channel or math waveforms can be saved to one of two reference waveform locations in the oscilloscope. Then, a reference waveform can be displayed and compared against other waveforms. One reference waveform can be displayed at a time.

Table 11  Reference Waveform Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference waveforms, display</td>
<td>[Ref] &gt; Display Ref</td>
</tr>
<tr>
<td>Reference waveforms, save</td>
<td>[Ref] &gt; Save/Clear &gt; Source, [Ref] &gt; Save/Clear &gt; Save to</td>
</tr>
<tr>
<td>Reference waveforms, skew</td>
<td>[Ref] &gt; Skew, ↜ Entry knob</td>
</tr>
<tr>
<td>Reference waveforms, scale</td>
<td>[Ref] &gt; Scale, ↜ Entry knob</td>
</tr>
<tr>
<td>Reference waveforms, offset</td>
<td>[Ref] &gt; Offset, ↜ Entry knob</td>
</tr>
<tr>
<td>Reference waveforms, clear</td>
<td>[Ref] &gt; Save/Clear &gt; Clear</td>
</tr>
<tr>
<td></td>
<td>[Save/Recall] &gt; Default/Erase &gt; Secure Erase</td>
</tr>
<tr>
<td>Reference waveforms, info</td>
<td>[Ref] &gt; Save/Clear &gt; Display Info</td>
</tr>
<tr>
<td>Reference waveforms, info,</td>
<td></td>
</tr>
<tr>
<td>transparent background</td>
<td>[Ref] &gt; Save/Clear &gt; Transparent</td>
</tr>
<tr>
<td>Reference waveforms, save/recall</td>
<td></td>
</tr>
<tr>
<td>from USB storage device</td>
<td>[Save/Recall] &gt; Save &gt; Format, Reference Waveform data (*.h5)</td>
</tr>
<tr>
<td></td>
<td>[Save/Recall] &gt; Recall &gt; Recall:, Reference Waveform data (*.h5)</td>
</tr>
</tbody>
</table>
Display Settings

You can adjust the intensity of displayed analog input channel waveforms to account for various signal characteristics, such as fast time/div settings and low trigger rates.

You can turn on waveform persistence, where the oscilloscope updates the display with new acquisitions, but does not immediately erase the results of previous acquisitions. All previous acquisitions are displayed with reduced intensity. New acquisitions are shown in their normal color with normal intensity.

Table 12  Display Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Waveform intensity (for analog input channels)</td>
<td>[Intensity] (small round key just below Entry knob)</td>
</tr>
<tr>
<td></td>
<td>Increasing the intensity lets you see the maximum amount of noise and infrequently occurring events. Reducing the intensity can expose more detail in complex signals.</td>
</tr>
<tr>
<td>Persistence, infinite</td>
<td>[Display] &gt; Persistence &gt; Persistence, ∞ Persistence</td>
</tr>
<tr>
<td>Persistence, variable</td>
<td>[Display] &gt; Persistence &gt; Persistence, Variable Persistence, [Display] &gt; Persistence &gt; Time, Entry knob</td>
</tr>
<tr>
<td>Clear persistence</td>
<td>[Display] &gt; Persistence &gt; Clear Persistence</td>
</tr>
<tr>
<td>Clear display</td>
<td>[Display] &gt; Clear Display</td>
</tr>
<tr>
<td></td>
<td>You can also configure the [Quick Action] key to clear the display. See “Configuring the [Quick Action] Key” on page 88.</td>
</tr>
<tr>
<td>Grid intensity</td>
<td>[Display] &gt; Grid &gt; Intensity, Entry knob</td>
</tr>
<tr>
<td>Grid type</td>
<td>[Display] &gt; Grid &gt; Grid (Full, mV, IRE)</td>
</tr>
<tr>
<td>Waveform labels</td>
<td>[Display] &gt; Labels</td>
</tr>
<tr>
<td></td>
<td>See also “To load a list of labels from a text file you create” on page 48.</td>
</tr>
<tr>
<td>Label library reset</td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Default Library</td>
</tr>
<tr>
<td>Annotations</td>
<td>[Display] &gt; Annotation</td>
</tr>
</tbody>
</table>
To load a list of labels from a text file you create

It may be convenient to create a list of labels using a text editor, then load the label list into the oscilloscope. This lets you type on a keyboard rather than edit the label list using the oscilloscope's controls.

You can create a list of up to 75 labels and load it into the oscilloscope. Labels are added to the beginning of the list. If more than 75 labels are loaded, only the first 75 are stored.

To load labels from a text file into the oscilloscope:

1. Use a text editor to create each label. Each label can be up to ten characters in length. Separate each label with a line feed.
2. Name the file labellist.txt and save it on a USB mass storage device such as a thumb drive.
**NOTE**

**Label List Management**

When you press the Library softkey, you will see a list of the last 75 labels used. The list does not save duplicate labels. Labels can end in any number of trailing digits. As long as the base string is the same as an existing label in the library, the new label will not be put in the library. For example, if label A0 is in the library and you make a new label called A12345, the new label is not added to the library.

When you save a new user-defined label, the new label will replace the oldest label in the list. Oldest is defined as the longest time since the label was last assigned to a channel. Any time you assign any label to a channel, that label will move to the newest in the list. Thus, after you use the label list for a while, your labels will predominate, making it easier to customize the instrument display for your needs.

When you reset the label library list (see next topic), all of your custom labels will be deleted, and the label list will be returned to its factory configuration.
Triggers

A trigger setup tells the oscilloscope when to acquire and display data. For example, you can set up to trigger on the rising edge of the analog channel 1 input signal.

You can use any input channel or the Ext Trig input BNC as the source for most trigger types (see "External Trigger Input" on page 53).

Changes to the trigger setup are applied immediately. If the oscilloscope is stopped when you change a trigger setup, the oscilloscope uses the new specification when you press [Run/Stop] or [Single]. If the oscilloscope is running when you change a trigger setup, it uses the new trigger definition when it starts the next acquisition.

You can save trigger setups along with the oscilloscope setup (see "Save/Recall (Setups, Screens, Data)" on page 82).

Trigger Knobs and Keys

Trigger Types

In addition to the edge trigger type, you can set up triggers on pulse widths and video signals. In the DSOX1000-Series oscilloscopes, you can also set up triggers on patterns, rising and falling edge transition times, and setup and hold violations.
**Table 13  Trigger Type Features**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trigger level</td>
<td>Turn the trigger Level knob.</td>
</tr>
<tr>
<td></td>
<td>Also: [Analyze] &gt; Features, Trigger Levels.</td>
</tr>
<tr>
<td></td>
<td>The edge trigger level for the Line source is not adjustable. This trigger is synchronized with the power line supplied to the oscilloscope.</td>
</tr>
<tr>
<td>Trigger type</td>
<td>[Trigger] &gt; Trigger Type (Edge, Pulse Width, Video, Serial 1, Pattern*, Rise/Fall Time*, Setup and Hold*)</td>
</tr>
<tr>
<td>Edge trigger</td>
<td>[Auto Scale] (sets up an Edge trigger)</td>
</tr>
<tr>
<td></td>
<td>[Trigger] &gt; Trigger Type, Edge</td>
</tr>
<tr>
<td>Pulse width trigger</td>
<td>[Trigger] &gt; Trigger Type, Pulse Width</td>
</tr>
<tr>
<td>Video trigger</td>
<td>[Trigger] &gt; Trigger Type, Video</td>
</tr>
<tr>
<td></td>
<td><strong>NOTE:</strong> Many video signals are produced from 75 Ω sources. To provide correct matching to these sources, a 75 Ω terminator (such as a Keysight 11094B) should be connected to the oscilloscope input.</td>
</tr>
<tr>
<td>Pattern trigger</td>
<td>[Trigger] &gt; Trigger Type, Pattern</td>
</tr>
<tr>
<td>Rise/fall edge transition time trigger</td>
<td>[Trigger] &gt; Trigger Type, Rise/Fall Time</td>
</tr>
<tr>
<td>Setup and hold violation trigger</td>
<td>[Trigger] &gt; Trigger Type, Setup and Hold</td>
</tr>
<tr>
<td>Serial bus trigger</td>
<td>[Trigger] &gt; Trigger Type, Serial 1</td>
</tr>
<tr>
<td></td>
<td>See “Serial Bus Decode/Trigger” on page 76.</td>
</tr>
</tbody>
</table>

* Pattern, Rise/Fall Time, and Setup and Hold trigger types are available on DSOX1000-Series models only

**Trigger Mode, Coupling, Reject, Holdoff**

**Noisy Signals**  If the signal you are probing is noisy, you can set up the oscilloscope to reduce the noise in the trigger path and on the displayed waveform. First, stabilize the displayed waveform by removing the noise from the trigger path. Second, reduce the noise on the displayed waveform.

1  Connect a signal to the oscilloscope and obtain a stable display.
2 Remove the noise from the trigger path by turning on high-frequency rejection, low-frequency rejection, or noise reject.

3 Use "Selecting the Acquisition Mode" on page 54 to reduce noise on the displayed waveform.

Table 14 Trigger Mode, Coupling, Reject, Holdoff Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trigger mode</td>
<td><strong>[Trigger] &gt; Mode</strong></td>
</tr>
<tr>
<td></td>
<td>You can also configure the [Quick Action] key to toggle between the Auto and Normal trigger modes. See &quot;Configuring the [Quick Action] Key&quot; on page 88.</td>
</tr>
<tr>
<td>Auto trigger mode</td>
<td><strong>[Trigger] &gt; Mode, Auto</strong></td>
</tr>
<tr>
<td></td>
<td>If the specified trigger conditions are not found, triggers are forced and acquisitions are made so that signal activity is displayed on the oscilloscope. The Auto trigger mode is appropriate when:</td>
</tr>
<tr>
<td></td>
<td>• Checking DC signals or signals with unknown levels or activity.</td>
</tr>
<tr>
<td></td>
<td>• When trigger conditions occur often enough that forced triggers are unnecessary.</td>
</tr>
<tr>
<td>Normal trigger mode</td>
<td><strong>[Trigger] &gt; Mode, Normal</strong></td>
</tr>
<tr>
<td></td>
<td>Triggers and acquisitions only occur when the specified trigger conditions are found. The Normal trigger mode is appropriate when:</td>
</tr>
<tr>
<td></td>
<td>• You only want to acquire specific events specified by the trigger settings.</td>
</tr>
<tr>
<td></td>
<td>• Making single-shot acquisitions with the [Single] key.</td>
</tr>
<tr>
<td></td>
<td>Often with single-shot acquisitions, you must initiate some action in the device under test, and you do not want the oscilloscope to auto-trigger before that happens. Before initiating the action in the circuit, wait for the trigger condition indicator <strong>Trig’d?</strong> to flash (this tells you the pre-trigger buffer is filled).</td>
</tr>
<tr>
<td>Force trigger</td>
<td><strong>[Force]</strong></td>
</tr>
<tr>
<td></td>
<td>When in the Normal trigger mode and no triggers are occurring, you can force a trigger to acquire and display waveforms (which may show why triggers are not occurring).</td>
</tr>
<tr>
<td>Trigger coupling</td>
<td><strong>[Trigger] &gt; Coupling (DC, AC, LF Reject, TV/Video)</strong></td>
</tr>
<tr>
<td></td>
<td><strong>NOTE:</strong> Trigger coupling is independent of channel coupling (see &quot;Vertical Controls&quot; on page 36).</td>
</tr>
<tr>
<td>Trigger noise reject</td>
<td><strong>[Trigger] &gt; Noise Rej</strong></td>
</tr>
<tr>
<td>Trigger high frequency reject</td>
<td><strong>[Trigger] &gt; HF Rej</strong></td>
</tr>
</tbody>
</table>
External Trigger Input

The external trigger input can be used as a source in several of the trigger types. The external trigger BNC input is labeled Ext Trig.

⚠️ Maximum voltage at oscilloscope external trigger input

150 Vrms, 200 Vpk

The external trigger input impedance is 1M Ohm. This lets you use passive probes for general-purpose measurements. The higher impedance minimizes the loading effect of the oscilloscope on the device under test.

Table 15  External Trigger Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>External trigger units</td>
<td>[External] &gt; Units (Volts, Amps)</td>
</tr>
<tr>
<td>External trigger attenuation</td>
<td>[External] &gt; Probe, Ratio/Decibels, ☐ Entry knob</td>
</tr>
<tr>
<td>External trigger threshold</td>
<td>[External] &gt; Threshold, ☐ Entry knob</td>
</tr>
<tr>
<td>External trigger range</td>
<td>[External] &gt; Range, ☐ Entry knob</td>
</tr>
<tr>
<td></td>
<td>For DSOX1000-Series oscilloscopes only. On EDUX1000-Series oscilloscopes, the range is fixed at 8 V when you are using a 1:1 probe.</td>
</tr>
<tr>
<td>External trigger waveform position</td>
<td>[External] &gt; Position, ☐ Entry knob</td>
</tr>
</tbody>
</table>
Acquisition Control

This section shows how to use the oscilloscope’s acquisition controls.

Selecting the Acquisition Mode

When selecting the oscilloscope acquisition mode, keep in mind that samples are normally decimated (thrown away) at slower time/div settings.

At slower time/div settings, the effective sample rate drops (and the effective sample period increases) because the acquisition time increases and the oscilloscope’s digitizer is sampling faster than is required to fill memory.

For example, suppose an oscilloscope’s digitizer has a sample period of 1 ns (maximum sample rate of 1 GSa/s) and a 1 M memory depth. At that rate, memory is filled in 1 ms. If the acquisition time is 100 ms (10 ms/div), only 1 of every 100 samples is needed to fill memory.

### Table 16 Acquisition Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acquisition mode</td>
<td>[Acquire] &gt; Acq Mode</td>
</tr>
<tr>
<td>Normal acquisition mode</td>
<td>[Acquire] &gt; Acq Mode, Normal</td>
</tr>
<tr>
<td></td>
<td>At slower time/div settings, normal decimation occurs, and there is no averaging. Use this mode for most waveforms.</td>
</tr>
<tr>
<td>Peak detect acquisition mode</td>
<td>[Acquire] &gt; Acq Mode, Peak Detect</td>
</tr>
<tr>
<td></td>
<td>At slower time/div settings when decimation would normally occur, the maximum and minimum samples in the effective sample period are stored. Use this mode for displaying narrow pulses that occur infrequently.</td>
</tr>
<tr>
<td>Averaging acquisition mode</td>
<td>[Acquire] &gt; Acq Mode, Averaging, [Acquire] &gt; # Avgs</td>
</tr>
<tr>
<td></td>
<td>At all time/div settings, the specified number of triggers are averaged together. Use this mode for reducing noise and increasing resolution of periodic signals without bandwidth or rise time degradation.</td>
</tr>
<tr>
<td>High resolution acquisition mode</td>
<td>[Acquire] &gt; Acq Mode, High Resolution</td>
</tr>
<tr>
<td></td>
<td>At slower time/div settings, all samples in the effective sample period are averaged and the average value is stored. Use this mode for reducing random noise.</td>
</tr>
</tbody>
</table>
Overview of Sampling

To understand the oscilloscope's sampling and acquisition modes, it is helpful to understand sampling theory, aliasing, oscilloscope bandwidth and sample rate, oscilloscope rise time, oscilloscope bandwidth required, and how memory depth affects sample rate.

Sampling Theory

The Nyquist sampling theorem states that for a limited bandwidth (band-limited) signal with maximum frequency $f_{\text{MAX}}$, the equally spaced sampling frequency $f_S$ must be greater than twice the maximum frequency $f_{\text{MAX}}$, in order to have the signal be uniquely reconstructed without aliasing.

$$f_{\text{MAX}} = \frac{f_S}{2} = \text{Nyquist frequency (} f_N \text{)} = \text{folding frequency}$$

Aliasing

Aliasing occurs when signals are under-sampled ($f_S < 2f_{\text{MAX}}$). Aliasing is the signal distortion caused by low frequencies falsely reconstructed from an insufficient number of sample points.

---

Table 17  Segmented Memory Acquisition Features, Available on DSOX1000-Series Models Only

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Segmented memory acquisitions</td>
<td>[Acquire] &gt; Segmented &gt; Segmented, # of Segs, [Run] or [Single]. After each segment fills, the oscilloscope re-arms and is ready to trigger in about 8 μs. Remember though, for example: if the horizontal time per division control is set to 5 μs/div, and the Time Reference is set to Center, it will take at least 50 μs to fill all ten divisions and re-arm. (That is 25 μs to capture pre-trigger data and 25 μs to capture post-trigger data.)</td>
</tr>
<tr>
<td>Segmented memory navigation</td>
<td>[Acquire] &gt; Segmented &gt; Current Seg</td>
</tr>
<tr>
<td>Segmented memory and persistence</td>
<td>[Display] &gt; Persistence, Infinite $\infty$ Persistence or Variable Persistence [Acquire] &gt; Segmented &gt; Analyze Segments</td>
</tr>
<tr>
<td>Segmented memory, save to USB storage device</td>
<td>[Save/Recall] &gt; Save &gt; Format (CSV, ASCII XY, or BIN) &gt; Settings &gt; Save Seg (Current, All)</td>
</tr>
</tbody>
</table>
Oscilloscope Bandwidth and Sample Rate

An oscilloscope's bandwidth is typically described as the lowest frequency at which input signal sine waves are attenuated by 3 dB (-30% amplitude error).

At the oscilloscope bandwidth, sampling theory says the required sample rate is $f_S = 2f_{BW}$. However, the theory assumes there are no frequency components above $f_{MAX}$ ($f_{BW}$ in this case) and it requires a system with an ideal brick-wall frequency response.
However, digital signals have frequency components above the fundamental frequency (square waves are made up of sine waves at the fundamental frequency and an infinite number of odd harmonics), and typically, for 500 MHz bandwidths and below, oscilloscopes have a Gaussian frequency response.

**Figure 4**  Theoretical Brick-Wall Frequency Response
So, in practice, an oscilloscope's sample rate should be four or more times its bandwidth: $f_S = 4f_{BW}$. This way, there is less aliasing, and aliased frequency components have a greater amount of attenuation.

See Also  

### Oscilloscope Rise Time

Closely related to an oscilloscope's bandwidth specification is its rise time specification. Oscilloscopes with a Gaussian–type frequency response have an approximate rise time of $0.35/f_{BW}$ based on a 10% to 90% criterion.

An oscilloscope's rise time is not the fastest edge speed that the oscilloscope can accurately measure. It is the fastest edge speed the oscilloscope can possibly produce.
Oscilloscope Bandwidth Required

The oscilloscope bandwidth required to accurately measure a signal is primarily determined by the signal's rise time, not the signal's frequency. You can use these steps to calculate the oscilloscope bandwidth required:

1  Determine the fastest edge speeds.
   You can usually obtain rise time information from published specifications for devices used in your designs.

2  Compute the maximum "practical" frequency component.

   From Dr. Howard W. Johnson's book, High-Speed Digital Design – A Handbook of Black Magic, all fast edges have an infinite spectrum of frequency components. However, there is an inflection (or "knee") in the frequency spectrum of fast edges where frequency components higher than \( f_{knee} \) are insignificant in determining the shape of the signal.

   \[
   f_{knee} = \frac{0.5}{\text{signal rise time}} \quad \text{(based on 10% - 90% thresholds)}
   \]

   \[
   f_{knee} = \frac{0.4}{\text{signal rise time}} \quad \text{(based on 20% - 80% thresholds)}
   \]

3  Use a multiplication factor for the required accuracy to determine the oscilloscope bandwidth required.

<table>
<thead>
<tr>
<th>Required accuracy</th>
<th>Oscilloscope bandwidth required</th>
</tr>
</thead>
<tbody>
<tr>
<td>20%</td>
<td>( f_{BW} = 1.0 \times f_{knee} )</td>
</tr>
<tr>
<td>10%</td>
<td>( f_{BW} = 1.3 \times f_{knee} )</td>
</tr>
<tr>
<td>3%</td>
<td>( f_{BW} = 1.9 \times f_{knee} )</td>
</tr>
</tbody>
</table>

See Also  Choosing an Oscilloscope with the Right Bandwidth for your Application, Keysight Application Note 1588  
(http://literature.cdn.keysight.com/litweb/pdf/5989-5733EN.pdf)

Memory Depth and Sample Rate

The number of points of oscilloscope memory is fixed, and there is a maximum sample rate associated with oscilloscope's analog-to-digital converter; however, the actual sample rate is determined by the time of the acquisition (which is set according to the oscilloscope's horizontal time/div scale).
sample rate = number of samples / time of acquisition

For example, when storing 50 µs of data in 50,000 points of memory, the actual sample rate is 1 GSa/s.

Likewise, when storing 50 ms of data in 50,000 points of memory, the actual sample rate is 1 MSa/s.

The actual sample rate is displayed in the right-side information area.

The oscilloscope achieves the actual sample rate by throwing away (decimating) unneeded samples.
Cursors

Cursors are horizontal and vertical markers that indicate X-axis values and Y-axis values on a selected waveform source. You can use cursors to make custom voltage, time, phase, or ratio measurements on oscilloscope signals.

Cursor information is displayed in the right-side information area.

**X Cursors**  
X cursors are vertical dashed lines that adjust horizontally and can be used to measure time (s), frequency (1/s), phase (°), and ratio (%).

When used with the FFT math function as a source, the X cursors indicate frequency.

In XY horizontal mode, the X cursors display channel 1 values (Volts or Amps).

**Y Cursors**  
Y cursors are horizontal dashed lines that adjust vertically and can be used to measure Volts or Amps, dependent on the channel **Probe Units** setting, or they can measure ratios (%). When math functions are used as a source, the measurement units correspond to that math function.

The Y cursors adjust vertically and typically indicate values relative to the waveform's ground point, except math FFT where the values are relative to 0 dB.

In XY horizontal mode, the Y cursors display channel 2 values (Volts or Amps).

Cursor Knobs and Keys

Cursor Softkey Controls
Table 18  Cursor Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cursors mode</td>
<td>[Cursors] &gt; Mode</td>
</tr>
<tr>
<td>Manual cursors mode</td>
<td>[Cursors] &gt; Mode, Manual (and use Cursors knob to select and adjust)</td>
</tr>
<tr>
<td>Track Waveform cursors mode</td>
<td>[Cursors] &gt; Mode, Track Waveform</td>
</tr>
<tr>
<td>Measure cursors mode</td>
<td>[Meas] (cursors show locations used for most recently added measurement)</td>
</tr>
<tr>
<td>Binary cursors mode</td>
<td>[Cursors] &gt; Mode, Binary</td>
</tr>
<tr>
<td>Hex cursors mode</td>
<td>[Cursors] &gt; Mode, Hex</td>
</tr>
<tr>
<td>Cursors X units</td>
<td>[Cursors] &gt; Units &gt; X Units (Seconds, Hz, Phase, Ratio)</td>
</tr>
<tr>
<td>Cursors Y units</td>
<td>[Cursors] &gt; Units &gt; Y Units (Base, Ratio)</td>
</tr>
</tbody>
</table>
Measurements

The [Meas] key lets you make automatic measurements on waveforms. Some measurements can only be made on analog input channels.

NOTE

If a portion of the waveform required for a measurement is not displayed or does not display enough resolution to make the measurement (approximately 4% of full scale), the result will be displayed as greater than a value, less than a value, not enough edges, not enough amplitude (low signal), or waveform is clipped.

The results of the most recent measurements are displayed in the Measurements information area on the right-hand side of the screen.

Cursors are turned on to show the portion of the waveform being measured for the most recently selected measurement (bottom-most on the right-side measurement are).

NOTE

Post Acquisition Processing

In addition to changing display parameters after the acquisition, you can perform all of the measurements and math functions after the acquisition. Measurements and math functions will be recalculated as you pan and zoom and turn channels on and off. As you zoom in and out on a signal using the horizontal scale knob and vertical volts/division knob, you affect the resolution of the display. Because measurements and math functions are performed on displayed data, you affect the resolution of functions and measurements.

The units of math waveforms are described in "Units for Math Waveforms" on page 45.

All measurements are available for analog channel waveforms. All measurements except Counter are available for math waveforms other than FFT. A limited set of measurements is available for math FFT waveforms. Use the cursors to make other measurements on FFT.
### Table 19  Measurement Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Measurement type</td>
<td>[Meas] &gt; Type:</td>
</tr>
<tr>
<td>Snapshot all measurements</td>
<td>[Meas] &gt; Type: Snapshot All, Add Measurement</td>
</tr>
<tr>
<td></td>
<td>You can also configure the [Quick Action] key to display the Snapshot All popup. See “Configuring the [Quick Action] Key” on page 88.</td>
</tr>
<tr>
<td>Voltage measurements</td>
<td>[Meas] &gt; Type: (Peak-Peak, Maximum, Minimum, Amplitude, Top, Base, Overshoot, Average, DC RMS, AC RMS), Add Measurement</td>
</tr>
<tr>
<td>Time measurements</td>
<td>[Meas] &gt; Type: (Period, Frequency, Counter, + Width, – Width, Duty Cycle, Rise Time, Fall Time, Delay, Phase), Add Measurement</td>
</tr>
<tr>
<td></td>
<td>The Counter measurement is available when the edge or pulse width trigger mode is selected and the measurement source is the same as the trigger source.</td>
</tr>
<tr>
<td>Measurement thresholds</td>
<td>[Meas] &gt; Settings &gt; Thresholds &gt;</td>
</tr>
<tr>
<td></td>
<td>Also: [Analyze] &gt; Features, Measurement Thresholds.</td>
</tr>
<tr>
<td>Measurement window</td>
<td>[Meas] &gt; Settings &gt; Meas Window (Auto Select, Main, Zoom)</td>
</tr>
<tr>
<td>Clear measurements</td>
<td>[Meas] &gt; Clear Meas &gt;</td>
</tr>
</tbody>
</table>
Mask Testing

Mask testing is available on the DSOX1000-Series oscilloscope models.

One way to verify a waveform's compliance to a particular set of parameters is to use mask testing. A mask defines a region of the oscilloscope's display in which the waveform must remain in order to comply with chosen parameters. Compliance to the mask is verified point-by-point across the display. Mask test operates on displayed analog channels; it does not operate on channels that are not displayed.

Table 20  Mask Testing Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mask testing enable/disable</td>
<td>[Analyze] &gt; Features, entry knob to select Mask Test, push entry knob to enable or disable</td>
</tr>
<tr>
<td>Mask statistics</td>
<td>[Analyze] &gt; Statistics &gt;</td>
</tr>
<tr>
<td>Mask test run until</td>
<td>[Analyze] &gt; Setup &gt; Run Until (Forever, Minimum # of Tests, Minimum Time, Minimum Sigma)</td>
</tr>
<tr>
<td>Mask test error action</td>
<td>[Analyze] &gt; Setup &gt; On Error (Stop, Save, Print, Measure)</td>
</tr>
<tr>
<td>Mask test source lock</td>
<td>[Analyze] &gt; Setup &gt; Source Lock</td>
</tr>
<tr>
<td>Auto mask creation</td>
<td>[Analyze] &gt; Automask &gt;</td>
</tr>
<tr>
<td>Clear mask</td>
<td>[Analyze] &gt; Clear Mask</td>
</tr>
<tr>
<td>Mask files, save/recall from USB</td>
<td>[Save/Recall] &gt; Save &gt; Format, Mask (*.msk)</td>
</tr>
<tr>
<td>storage device</td>
<td>[Save/Recall] &gt; Recall &gt; Recall, Mask (*.msk)</td>
</tr>
</tbody>
</table>

Creating/Editing Mask Files

A mask file contains the following sections:
- Mask File Identifier.
- Mask Title.
- Mask Violation Regions.
- Oscilloscope Setup Information.

Mask File Identifier  The Mask File Identifier is MASK_FILE_548XX.
Mask Title

The Mask Title is a string of ASCII characters. Example: autoMask CH1 OCT 03 09:40:26 2008

When a mask file contains the keyword "autoMask" in the title, the edge of the mask is passing by definition. Otherwise, the edge of the mask is defined as a failure.

Mask Violation

Up to 8 regions can be defined for a mask. They can be numbered 1-8. They can appear in any order in the .msk file. The numbering of the regions must go from top to bottom, left to right.

An Automask file contains two special regions: the region "glued" to the top of the display, and the region that is "glued" to the bottom. The top region is indicated by y-values of "MAX" for the first and last points. The bottom region is indicated by y-values of "MIN" for the first and last points.

The top region must be the lowest numbered region in the file. The bottom region must be the highest numbered region in the file.

Region number 1 is the top mask region. The vertices in Region 1 describe points along a line; that line is the bottom edge of the top portion of the mask.

Similarly, the vertices in Region 2 describe the line that forms the top of the bottom part of the mask.
The vertices in a mask file are normalized. There are four parameters that define how values are normalized:
- \( X_1 \)
- \( \Delta X \)
- \( Y_1 \)
- \( Y_2 \)

These four parameters are defined in the Oscilloscope Setup portion of the mask file.

The \( Y \)-values (normally voltage) are normalized in the file using the following equation:

\[
Y_{\text{norm}} = \frac{Y - Y_1}{\Delta Y}
\]

where \( \Delta Y = Y_2 - Y_1 \)

To convert the normalized \( Y \)-values in the mask file to voltage:

\[
Y = \left( Y_{\text{norm}} \times \Delta Y \right) + Y_1
\]

where \( \Delta Y = Y_2 - Y_1 \)

The \( X \)-values (normally time) are normalized in the file using the following equation:

\[
X_{\text{norm}} = \frac{X - X_1}{\Delta X}
\]

To convert the normalized \( X \)-values to time:

\[
X = \left( X_{\text{norm}} \times \Delta X \right) + X_1
\]

### Oscilloscope Setup Information

The keywords "setup" and "end_setup" (appearing alone on a line) define the beginning and end of the oscilloscope setup region of the mask file. The oscilloscope setup information contains remote programming language commands that the oscilloscope executes when the mask file is loaded.

Any legal remote programming command can be entered in this section.

The mask scaling controls how the normalized vectors are interpreted. This in turn controls how the mask is drawn on the display. The remote programming commands that control mask scaling are:

- `:MTES:SCAL:BIND 0`
- `:MTES:SCAL:X1 -400.000E-06`
- `:MTES:SCAL:XDEL +800.000E-06`
Building a Mask File

The following display shows a mask that uses all eight regions.

This mask is created by recalling the following mask file:

MASK_FILE_548XX

"All Regions"

/* Region Number */ 1
/* Number of vertices */ 4
-12.50, MAX
-10.00, 1.750
10.00, 1.750
12.50, MAX

/* Region Number */ 2
/* Number of vertices */ 5
-10.00, 1.000
-12.50, 0.500
-15.00, 0.500
-15.00, 1.500
-12.50, 1.500

/* Region Number */ 3
/* Number of vertices */ 6
-05.00, 1.000
-02.50, 0.500
02.50, 0.500
05.00, 1.000
02.50, 1.500
-02.50, 1.500

/* Region Number */ 4
/* Number of vertices */ 5
10.00, 1.000
12.50, 0.500
15.00, 0.500
15.00, 1.500
12.50, 1.500

/* Region Number */ 5
/* Number of vertices */ 5
-10.00, -1.000
-12.50, -0.500
-15.00, -0.500
-15.00, -1.500
-12.50, -1.500

/* Region Number */ 6
/* Number of vertices */ 6
-05.00, -1.000
-02.50, -0.500
02.50, -0.500
05.00, -1.000
02.50, -1.500
-02.50, -1.500

/* Region Number */ 7
/* Number of vertices */ 5
10.00, -1.000
12.50, -0.500
15.00, -0.500
15.00, -1.500
12.50, -1.500

/* Region Number */ 8
/* Number of vertices */ 4
-12.50, MIN
-10.00, -1.750
10.00, -1.750
12.50, MIN

setup
:CHANnel1:RANGE +8.00E+00
:CHANnel1:OFFSET +2.0E+00
:CHANnel1:DISPLAY 1
:TIMebase:MODE MAIN
:TIMebase:REFERENCE CENTER
:TIMebase:RANGE +50.00E-09
:TIMebase:POSITION +10.0E-09
:MTEST:SOURce CHANnel1
:MTEST:ENABLE 1
:MTEST:LOCK 1
:MTEST:SCALe:X1 +10.0E-09
:MTEST:SCALe:XDELta +1.0000E-09
:MTEST:SCALe:Y1 +2.0E+00
:MTEST:SCALe:Y2 +4.00000E+00
end_setup
In a mask file, all region definitions need to be separated by a blank line.

Mask regions are defined by a number of (x,y) coordinate vertices (as on an ordinary x,y graph). A "y" value of "MAX" specifies the top of the graticule, and a "y" value of "MIN" specifies the bottom of the graticule.

The mask x,y graph is related to the oscilloscope graticule using the :MTESt:SCALe setup commands.

The oscilloscope's graticule has a time reference location (at the left, center, or right of the screen) and a trigger (t=0) position/delay value relative to the reference. The graticule also has a vertical ground 0 V reference (offset relative to the center of the screen) location.

The X1 and Y1 setup commands relate the mask region's x,y graph origin to the oscilloscope graticule's t=0 and V=0 reference locations, and the XDELta and Y2 setup commands specify the size of the graph's x and y units.

- The X1 setup command specifies the time location of the x,y graph's x origin.
- The Y1 setup command specifies the vertical location of the x,y graph's y origin.
- The XDELta setup command specifies the amount of time associated with each x unit.
- The Y2 setup command is the vertical location of the x,y graph's y=1 value (so in effect, Y2 – Y1 is the YDELta value).

For example:

- With a graticule whose trigger position is 10 ns (before a center screen reference) and whose ground reference (offset) is 2 V below the center of the screen, to place the mask region's x,y graph's origin at center screen, you would set X1 = 10 ns and Y1 = 2 V.
- If the XDELta parameter is set to 5 ns and Y2 is set to 4 V, a mask region whose vertices are (-1, 1), (1, 1), (1, -1), and (-1, -1) goes from 5 ns to 15 ns and from 0 V to 4 V.
- If you move the mask region's x,y graph origin to the t=0 and V=0 location by setting X1 = 0 and Y1 = 0, the same vertices define a region that goes from -5 ns to 5 ns and from -2 V to 2 V.

**NOTE**

Although a mask can have up to 8 regions, in any given vertical column, it is only possible to define 4 regions. When there are 4 regions in a vertical column, one region must be tied to the top (using the MAX y value) and one must be tied to the bottom (using the MIN y value).
**How is mask testing done?** InfiniVision oscilloscopes start mask testing by creating a database that is 200 x 640 for the waveform viewing area. Each location in the array is designated as either a violation or a pass area. Each time a data point from a waveform occurs in a violation area a failure is logged. If **Test All** was selected, every active analog channel is tested against the mask database for each acquisition. Over 2 billion failures can be logged per-channel. The number of acquisitions tested is also logged and displayed as "# of Tests".

The mask file allows greater resolution than the 200 X 640 database. Some quantization of data occurs to reduce the mask file data for display on-screen.
Digital Voltmeter

The Digital Voltmeter (DVM) analysis feature provides 3-digit voltage and 5-digit frequency measurements using any analog channel. DVM measurements are asynchronous from the oscilloscope’s acquisition system and are always acquiring.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
</table>
| Digital voltmeter enable/disable | [Analyze] > Features,  
Entry knob to select Digital Voltmeter, push Entry knob to enable or disable                                                                        |
| Digital voltmeter mode | [Analyze] > Mode (AC RMS, DC, DC RMS, Frequency)                                                                                       |
|                      | The Frequency mode requires the Edge or Pulse Width trigger type, and the DVM source and the trigger source must be the same analog channel.                                                              |
| Auto range enable/disable | [Analyze] > Auto Range                                                                                                                |
|                      | Auto range can be used when the DVM input channel is not used in oscilloscope triggering.                                                                                                           |
Frequency Response Analysis

On G-suffix oscilloscope models (that have a built-in waveform generator), the Frequency Response Analysis (FRA) feature controls the built-in waveform generator to sweep a sine wave across a range of frequencies while measuring the input to and output from a device under test (DUT). At each frequency, gain (A) and phase are measured and plotted on a frequency response Bode chart.

When the frequency response analysis completes, you can move a marker across the chart to see the measured gain and phase values at each frequency point. You can also adjust the chart's scale and offset settings for the gain and phase plots.

Table 22  Frequency Response Analysis Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frequency Response Analysis (FRA) enable/disable</td>
<td>[Analyze] &gt; Features,.Entry knob to select Frequency Response Analysis, push Entry knob to enable or disable</td>
</tr>
<tr>
<td>Channels probing DUT input V and output V</td>
<td>[Analyze] &gt; Setup &gt; Input V, [Analyze] &gt; Setup &gt; Output V</td>
</tr>
<tr>
<td>Frequency sweep min and max values</td>
<td>[Analyze] &gt; Setup &gt; Min/Max Freq, Entry knob</td>
</tr>
<tr>
<td>Waveform generator amplitude and expected output load</td>
<td>[Analyze] &gt; Setup &gt; Amplitude, Entry knob, [Analyze] &gt; Setup &gt; Output Load (50 Ω, High-Z)</td>
</tr>
<tr>
<td>Points per decade</td>
<td>[Analyze] &gt; Setup &gt; Pts Per Decade (10, 20, 30, 40, 50)</td>
</tr>
<tr>
<td>Run the analysis</td>
<td>[Analyze] &gt; Run Analysis</td>
</tr>
<tr>
<td>Adjust scale and offset of Bode plots</td>
<td>[Analyze] &gt; Chart &gt; Gain/Phase Scale/Offset, Entry knob</td>
</tr>
<tr>
<td>Gain, Phase, or both plots in chart</td>
<td>[Analyze] &gt; Chart &gt; Trace (Gain, Phase, both)</td>
</tr>
<tr>
<td>Autoscale gain and phase plots</td>
<td>[Analyze] &gt; Chart &gt; Autoscale</td>
</tr>
<tr>
<td>View measured gain and phase values</td>
<td>[Analyze] &gt; Move Marker, Entry knob</td>
</tr>
</tbody>
</table>
**Table 22  Frequency Response Analysis Features (continued)**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save data to USB storage device</td>
<td>[Save/Recall] &gt; Save &gt; Format, Frequency Response Analysis data (*.csv)</td>
</tr>
</tbody>
</table>
Waveform Generator

On G-suffix oscilloscope models, a waveform generator is built into the oscilloscope. The waveform generator gives you an easy way to provide input signals when testing circuitry with the oscilloscope.

Waveform generator settings can be saved and recalled with oscilloscope setups. See "Save/Recall (Setups, Screens, Data)" on page 82.

Table 23  Waveform Generator Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Waveform generator waveform type</td>
<td>[Wave Gen] &gt; Waveform (Sine, Square, Ramp, Pulse, DC, Noise)</td>
</tr>
<tr>
<td>Waveform generator expected output load</td>
<td>[Wave Gen] &gt; Settings &gt; Output Settings &gt; Output Load (50 Ω, High-Z)</td>
</tr>
<tr>
<td>Waveform generator sync pulse output</td>
<td>[Wave Gen] &gt; Settings &gt; Output Settings &gt; Trig Out, Waveform Generator Sync Pulse For all waveforms except DC and Noise, the Sync signal is a TTL positive pulse that occurs when the waveform rises above zero volts (or the DC offset value).</td>
</tr>
<tr>
<td>Waveform generator logic presets</td>
<td>[Wave Gen] &gt; Settings &gt; Logic Presets &gt; (TTL, CMOS 5.0V, CMOS 3.3V, CMOS 2.5V, ECL)</td>
</tr>
<tr>
<td>Add noise to output</td>
<td>[Wave Gen] &gt; Settings &gt; Add Noise</td>
</tr>
<tr>
<td>Modulation, enable/disable</td>
<td>[Wave Gen] &gt; Settings &gt; Modulation &gt; Modulation</td>
</tr>
<tr>
<td>AM modulated output</td>
<td>[Wave Gen] &gt; Settings &gt; Modulation &gt; Type, Amplitude Modulation (AM)</td>
</tr>
<tr>
<td>FM modulated output</td>
<td>[Wave Gen] &gt; Settings &gt; Modulation &gt; Type, Frequency Modulation (FM)</td>
</tr>
<tr>
<td>FSK modulated output</td>
<td>[Wave Gen] &gt; Settings &gt; Modulation &gt; Type, Frequency-Shift Keying Modulation (FSK)</td>
</tr>
<tr>
<td>Restore waveform generator defaults</td>
<td>[Wave Gen] &gt; Settings &gt; Default Wave Gen</td>
</tr>
</tbody>
</table>
Serial Bus Decode/Trigger

Depending on the oscilloscope model, the following hardware-accelerated serial decode and trigger options are available:

<table>
<thead>
<tr>
<th>Serial decode and trigger type</th>
<th>Available on</th>
<th>With license</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAN (Controller Area Network)</td>
<td>DSOX1000-Series models</td>
<td>AUTO</td>
</tr>
<tr>
<td>I2C (Inter-IC)</td>
<td>All 1000 X-Series models</td>
<td>EMBD</td>
</tr>
<tr>
<td>LIN (Local Interconnect Network)</td>
<td>DSOX1000-Series models</td>
<td>AUTO</td>
</tr>
<tr>
<td>SPI (Serial Peripheral Interface)</td>
<td>DSOX1000-Series models</td>
<td>EMBD</td>
</tr>
<tr>
<td>UART (Universal Asynchronous Receiver/Transmitter) protocols including RS232 (Recommended Standard 232)</td>
<td>All 1000 X-Series models</td>
<td>EMBD</td>
</tr>
</tbody>
</table>

To determine whether these licenses are installed on your oscilloscope, press [Help] > About Oscilloscope.

To order serial decode licenses, go to www.keysight.com and search for the product number (for example, DSOX1AUTO) or contact your local Keysight Technologies representative (see www.keysight.com/find/contactus).

Triggering on Serial Data

When triggering on a slow serial signal (for example, I2C, SPI, CAN, LIN, etc.) it may be necessary to switch from the Auto trigger mode to the Normal trigger mode to prevent the oscilloscope from Auto-triggering and stabilize the display. You can select the trigger mode by pressing the [Trigger] key, then the Mode softkey.

Also, the threshold voltage level must be set appropriately for each source channel. The threshold level for each serial signal can be set in the Signals menu. Press the [Bus] key, then the Signals softkey.
On DSOX1000-Series oscilloscopes, the CAN serial decode and triggering option can be enabled with the AUTO license.

When interpreting the decode waveforms, see the **Mode** softkey built-in help.

### Table 24  Serial Bus Decode/Trigger Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Serial bus select, enable/disable</td>
<td>[Bus] &gt; Select,  ( \Rightarrow ) Entry knob to select Serial Bus, push Select softkey or Entry knob to enable or disable</td>
</tr>
<tr>
<td>Serial bus mode</td>
<td>[Bus] &gt; Mode,  ( \Rightarrow ) Entry knob (CAN(^<em>), I2C, LIN(^</em>), SPI(^*), UART/RS232)</td>
</tr>
<tr>
<td></td>
<td>The built-in help for the <strong>Mode</strong> softkey describes the decode waveforms.</td>
</tr>
<tr>
<td>Serial bus trigger</td>
<td>[Trigger] &gt; Trigger Type, Serial 1</td>
</tr>
</tbody>
</table>

\(^*\) CAN, LIN, and SPI are available on DSOX1000-Series models only

### Table 25  CAN Decode/Trigger Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAN signal setup</td>
<td>After selecting the Serial Bus and the CAN serial bus mode, press [Bus] &gt; Signals &gt; to open the CAN Signals menu. In this menu, you can select the oscilloscope source channel probing the signal and the appropriate threshold voltage to use when decoding/trIGGERING the signal, as well as other signal options.</td>
</tr>
<tr>
<td>CAN baud rate</td>
<td>[Bus] &gt; Signals &gt; Baud,  ( \Rightarrow ) Entry knob</td>
</tr>
<tr>
<td>CAN sample point</td>
<td>[Bus] &gt; Signals &gt; Sample Point,  ( \Rightarrow ) Entry knob</td>
</tr>
<tr>
<td>CAN signal type/polarity</td>
<td>[Bus] &gt; Signals &gt; Signal,  ( \Rightarrow ) Entry knob (Rx, Tx, CAN(_H), CAN(_L), Differential (L-H), Differential (H-L))</td>
</tr>
<tr>
<td>CAN counters</td>
<td>[Bus] &gt; Reset CAN Counters</td>
</tr>
<tr>
<td></td>
<td>Counters run even when the oscilloscope is stopped (not acquiring data). When an overflow condition occurs, the counter displays OVERFLOW.</td>
</tr>
</tbody>
</table>
Table 25  CAN Decode/Trigger Features (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAN trigger</td>
<td>[Trigger] &gt; Trigger Type, Serial 1 (CAN)</td>
</tr>
<tr>
<td></td>
<td>[Trigger] &gt; Trigger on: (SOF - Start of Frame, Remote Frame ID (RTR), Data Frame ID (-RTR), Remote or Data Frame ID, Data Frame ID and Data, Error Frame, All Errors, Acknowledge Error, Overload Frame)</td>
</tr>
<tr>
<td></td>
<td>For triggers where you can specify frame ID or data values, press [Trigger] &gt; Bits &gt; to open the CAN Bits menu where you can enter the values.</td>
</tr>
</tbody>
</table>

I2C Decode/Trigger

On all 1000 X-Series oscilloscopes, the I2C serial decode and triggering option can be enabled with the EMBD license.

When interpreting the decode waveforms, see the Mode softkey built-in help.

Table 26  I2C Decode/Trigger Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>I2C signal setup</td>
<td>After selecting the Serial Bus and the I2C serial bus mode, press [Bus] &gt; Signals &gt; to open the I2C Signals menu. In this menu, you can select the oscilloscope source channels probing the serial clock and serial data signals. You can also specify the appropriate threshold voltages to use when decoding and triggering on the signals.</td>
</tr>
<tr>
<td>I2C address size</td>
<td>[Bus] &gt; Addr Size (7 Bit, 8 Bit)</td>
</tr>
<tr>
<td>I2C trigger</td>
<td>[Trigger] &gt; Trigger Type, Serial 1 (I2C)</td>
</tr>
<tr>
<td></td>
<td>[Trigger] &gt; Trigger on: (Start Condition, Stop Condition, Missing Acknowledge, Address with no Ack, Restart, EEPROM Data Read, Frame (Start: Addr7: Read: Ack: Data), Frame (Start: Addr7: Write: Ack: Data), Frame (Start: Addr7: Read: Ack: Data: Ack: Data2), Frame (Start: Addr7: Write: Ack: Data: Ack: Data2), 10-bit Write)</td>
</tr>
<tr>
<td></td>
<td>For triggers where you can specify address or data values, there are additional softkeys you can use to enter the values.</td>
</tr>
</tbody>
</table>

LIN Decode/Trigger

On DSOX1000-Series oscilloscopes, the LIN serial decode and triggering option can be enabled with the AUTO license.
When interpreting the decode waveforms, see the **Mode** softkey built-in help.

### Table 27 LIN Decode/Trigger Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIN signal setup</td>
<td>After selecting the Serial Bus and the LIN serial bus mode, press <strong>[Bus]</strong> &gt; <strong>Signals</strong> &gt; to open the LIN Signals menu. In this menu, you can select the oscilloscope source channel probing the signal and the appropriate threshold voltage to use when decoding/triggering the signal, as well as other signal options.</td>
</tr>
<tr>
<td>LIN baud rate</td>
<td><strong>[Bus]</strong> &gt; <strong>Signals</strong> &gt; <strong>Baud</strong>, <img src="image" alt="Entry knob" /></td>
</tr>
<tr>
<td>LIN sample point</td>
<td><strong>[Bus]</strong> &gt; <strong>Signals</strong> &gt; <strong>Sample Point</strong>, <img src="image" alt="Entry knob" /></td>
</tr>
<tr>
<td>LIN standard</td>
<td><strong>[Bus]</strong> &gt; <strong>Signals</strong> &gt; <strong>Standard</strong>, <img src="image" alt="Entry knob" /> (LIN 1.3, LIN 2.X)</td>
</tr>
<tr>
<td>LIN sync break</td>
<td><strong>[Bus]</strong> &gt; <strong>Signals</strong> &gt; <strong>Sync Break</strong>, <img src="image" alt="Entry knob" /> (&gt;= 11, &gt;= 12, &gt;= 13)</td>
</tr>
<tr>
<td>LIN show parity</td>
<td><strong>[Bus]</strong> &gt; <strong>Show Parity</strong></td>
</tr>
</tbody>
</table>
| LIN trigger        | **[Trigger]** > **Trigger Type, Serial 1 (LIN)**  
**[Trigger]** > **Trigger on**: (Sync - Sync Break, ID - Frame ID, ID & Data - Frame ID and Data, Parity Error, Checksum Error)                                                                 |

For triggers where you can specify frame ID or data values, there are additional softkeys you can use to enter the values.

### SPI Decode/Trigger

On DSOX1000-Series oscilloscopes, the SPI serial decode and triggering option can be enabled with the EMBD license.

When interpreting the decode waveforms, see the **Mode** softkey built-in help.
UART/RS232 Decode/Trigger

On all 1000 X-Series oscilloscopes, the UART/RS232 serial decode and triggering option can be enabled with the EMBD license.

When interpreting the decode waveforms, see the **Mode** softkey built-in help.

Table 29  UART/RS232 Decode/Trigger Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>UART/RS232 signal setup</td>
<td>After selecting the Serial Bus and the UART/RS232 serial bus mode, press [Bus] &gt; Signals &gt; to open the UART Signals menu. In this menu, you can select the oscilloscope source channels probing the Rx and Tx signals and the appropriate threshold voltage for each.</td>
</tr>
<tr>
<td>UART/RS232 bus configuration</td>
<td>After selecting the Serial Bus and the UART/RS232 serial bus mode, press [Bus] &gt; Bus Config &gt; to open the UART Bus Config menu. In this menu, you can select the oscilloscope source channels probing the Rx and Tx signals and the appropriate threshold voltage for each.</td>
</tr>
<tr>
<td>UART/RS232 number of bits</td>
<td>[Bus] &gt; Bus Config &gt; # Bits, Entry knob (5, 6, 7, 8, 9)</td>
</tr>
</tbody>
</table>
Table 29  UART/RS232 Decode/Trigger Features (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>UART/RS232 parity</td>
<td>[Bus] &gt; Bus Config &gt; Parity, ➕ Entry knob (Even, Odd, None)</td>
</tr>
<tr>
<td>UART/RS232 baud rate</td>
<td>[Bus] &gt; Bus Config &gt; Baud Rate &gt; Baud, ➕ Entry knob</td>
</tr>
<tr>
<td>UART/RS232 bus polarity</td>
<td>[Bus] &gt; Bus Config &gt; Polarity, ➕ Entry knob (Idle low, Idle high)</td>
</tr>
<tr>
<td>UART/RS232 bit order</td>
<td>[Bus] &gt; Bus Config &gt; Bit Order, ➕ Entry knob (LSB, MSB)</td>
</tr>
<tr>
<td>UART/RS232 display base</td>
<td>[Bus] &gt; Settings &gt; Base, ➕ Entry knob (Hex, Binary, ASCII)</td>
</tr>
<tr>
<td>UART/RS232 framing</td>
<td>[Bus] &gt; Settings &gt; Framing, ➕ Entry knob (Off, 8-bit hex value)</td>
</tr>
<tr>
<td>UART/RS232 counters</td>
<td>[Bus] &gt; Settings &gt; Reset UART Counters</td>
</tr>
<tr>
<td></td>
<td>Counters run even when the oscilloscope is stopped (not acquiring data).</td>
</tr>
<tr>
<td></td>
<td>When an overflow condition occurs, the counter displays OVERFLOW.</td>
</tr>
<tr>
<td>UART/RS232 trigger</td>
<td>[Trigger] &gt; Trigger Type, Serial 1 (CAN)</td>
</tr>
<tr>
<td></td>
<td>[Trigger] &gt; Trigger Setup &gt; Trigger (Rx Start Bit, Rx Stop Bit, Rx Data, Rx 1:Data, Rx 0:Data, Rx X:Data, Tx Start Bit, Tx Stop Bit, Tx Data, Tx 1:Data, Tx 0:Data, Tx X:Data, Rx or Tx Parity Error)</td>
</tr>
<tr>
<td></td>
<td>For triggers where you can specify data values, there are additional softkeys for specifying the data comparison operator, the data value, the data value base (Hex or ASCII), and the Nth frame burst count.</td>
</tr>
</tbody>
</table>
Save/Recall (Setups, Screens, Data)

Oscilloscope setups, reference waveforms, and mask files can be saved to internal oscilloscope memory or to a USB storage device and recalled later. You can also recall default or factory default setups.

Oscilloscope screen images can be saved to a USB storage device in BMP or PNG formats.

Acquired waveform data can be saved to a USB storage device in comma-separated value (CSV), ASCII XY, and binary (BIN) formats.

There is also a command to securely erase all the oscilloscope's non-volatile internal memory.

Table 30  Save/Recall Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save setup files, screen images, waveform data, mask files</td>
<td>[Save/Recall] &gt; Save &gt; You can also configure the [Quick Action] key to save setups, screen images, or data. See &quot;Configuring the [Quick Action] Key&quot; on page 88.</td>
</tr>
<tr>
<td>Save setup files</td>
<td>[Save/Recall] &gt; Save &gt; Format, Setup (*.scp) Press to Save</td>
</tr>
<tr>
<td>Save screen images</td>
<td>[Save/Recall] &gt; Save &gt; Format,</td>
</tr>
<tr>
<td></td>
<td>• 8-bit Bitmap image (*.bmp)</td>
</tr>
<tr>
<td></td>
<td>• 24-bit Bitmap image (*.bmp)</td>
</tr>
<tr>
<td></td>
<td>• 24-bit image (*.png)</td>
</tr>
<tr>
<td></td>
<td>Settings &gt;</td>
</tr>
<tr>
<td></td>
<td>• Setup Info</td>
</tr>
<tr>
<td></td>
<td>• Invert Grat</td>
</tr>
<tr>
<td></td>
<td>• Palette (Color, Grayscale)</td>
</tr>
</tbody>
</table>
Length Control

The **Length** control is available when saving data to CSV, ASCII XY, or BIN format files. It sets the number of data points that will be output to the file. Only displayed data points are saved.

The maximum number of data points depends on these things:

- Whether acquisitions are running. When stopped, data comes from the raw acquisition record. When running, data comes from the smaller measurement record.
- Whether the oscilloscope was stopped using [Stop] or [Single]. Running acquisitions split memory to provide fast waveform update rates. Single acquisitions use full memory.
- Whether only one channel of a pair is turned on. (Channels 1 and 2 are one pair.) Acquisition memory is divided among the channels in a pair.

### Table 30  Save/Recall Features (continued)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save waveform data</td>
<td>[Save/Recall] &gt; Save &gt; Format, CSV data (<em>.csv), ASCII XY data (</em>.csv), Multi Channel Waveform data (<em>.h5), Binary data (</em>.bin)</td>
</tr>
<tr>
<td></td>
<td>Settings &gt; Length (to select number of data points to be saved, see &quot;Length Control&quot; on page 83)</td>
</tr>
<tr>
<td></td>
<td>When saving waveform data, the save times depend on the chosen format: BIN=fastest, ASCII XY=medium, CSV=slowest.</td>
</tr>
<tr>
<td>Quick save to USB storage device</td>
<td>[Save to USB] (once <em>save to USB</em> settings have been configured under [Save/Recall] &gt; Save)</td>
</tr>
<tr>
<td>Recall setups, mask files, or reference waveforms</td>
<td>[Save/Recall] &gt; Recall &gt; Recall:</td>
</tr>
<tr>
<td>Recall setup files</td>
<td>[Save/Recall] &gt; Recall &gt; Recall:, Setup (*.scp)</td>
</tr>
<tr>
<td>Factory default setup</td>
<td>[Save/Recall] &gt; Default/Erase &gt; Factory Default</td>
</tr>
<tr>
<td>Secure erase</td>
<td>[Save/Recall] &gt; Default/Erase &gt; Secure Erase</td>
</tr>
</tbody>
</table>
Quick Reference

- Whether reference waveforms are on. Displayed reference waveforms consume acquisition memory.
- Whether segmented memory (available on DSOX1000-Series models) is on. Acquisition memory is divided by the number of segments.
- The horizontal time/div (sweep speed) setting. At faster settings, fewer data points appear on the display.
- When saving to a CSV format file, the maximum number of data points is 50,000.

When necessary, the Length control performs a "1 of n" decimation of the data. For example: if the Length is set to 1000, and you are displaying a record that is 5000 data points in length, four of each five data points will be decimated, creating an output file 1000 data points in length.
Print (Screens)

You can print the complete display, including the status line and softkeys, to a USB printer.

To set up a USB printer:
1. Connect a USB printer to the USB host port on the front panel.
2. To open the Print Config menu:
   - Press [Save/Recall] > Print.
   - Select the Quick Print quick action ([Utility] > Quick Action > Action, Quick Print); then, press Settings.

Softkeys in the Print Config menu are ghosted (not available) until a printer is connected.

<table>
<thead>
<tr>
<th>Table 31</th>
<th>Print Config Menu Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feature</td>
<td>Front Panel Key/Softkey Location (see built-in help for more information)</td>
</tr>
<tr>
<td>Printer selection</td>
<td>Print to, (printer)</td>
</tr>
<tr>
<td>Print options</td>
<td>Options,</td>
</tr>
<tr>
<td></td>
<td>• Setup Information</td>
</tr>
<tr>
<td></td>
<td>• Invert Graticule Colors</td>
</tr>
<tr>
<td></td>
<td>• Form Feed</td>
</tr>
<tr>
<td></td>
<td>• Landscape</td>
</tr>
<tr>
<td>Color or grayscale printing</td>
<td>Palette, (Color, Grayscale)</td>
</tr>
<tr>
<td>Print the current screen</td>
<td>Press to Print</td>
</tr>
</tbody>
</table>

To print the current screen once the printer is configured (and Quick Print is selected as the quick action), simply press the [Quick Action] key.

For the most up-to-date listing of printers that are compatible with the InfiniiVision oscilloscopes, please visit www.keysight.com/find/InfiniiVision-printers.
Utility Settings

This section explains oscilloscope utility functions.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>I/O setup</strong></td>
<td>[Utility] &gt; I/O &gt;</td>
</tr>
<tr>
<td></td>
<td>The oscilloscope can be accessed and/or controlled remotely using the USB device port on the rear panel (square shaped USB port). See the oscilloscope’s Programmer’s Guide.</td>
</tr>
<tr>
<td><strong>File explorer</strong></td>
<td>[Utility] &gt; File Explorer &gt;</td>
</tr>
<tr>
<td></td>
<td>From the internal file system, under &quot;User Files&quot;, you can load oscilloscope setup files (from 10 locations) or mask files (from four locations).</td>
</tr>
<tr>
<td></td>
<td>From a connected USB storage device, you can load setup files, mask files, license files, firmware update (*.cab) files, label files, etc. Also, you can delete files on a connected USB storage device. See also &quot;USB Storage Devices&quot; on page 87.</td>
</tr>
<tr>
<td></td>
<td>The rectangular USB port on the front panel is a USB Series A receptacle to which you can connect USB mass storage devices and printers.</td>
</tr>
<tr>
<td><strong>V/div expansion options</strong></td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Expand,</td>
</tr>
<tr>
<td></td>
<td>- Ground</td>
</tr>
<tr>
<td></td>
<td>- Center</td>
</tr>
<tr>
<td><strong>Transparent backgrounds</strong></td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Transparent</td>
</tr>
<tr>
<td><strong>Screen saver</strong></td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Screen Saver &gt;</td>
</tr>
<tr>
<td><strong>Autoscale preferences</strong></td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Autoscale &gt;</td>
</tr>
<tr>
<td><strong>Undo Autoscale</strong></td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Autoscale &gt; Undo Autoscale</td>
</tr>
<tr>
<td><strong>Fast debug Autoscale</strong></td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Autoscale &gt; Fast Debug</td>
</tr>
<tr>
<td><strong>Channels to be autoscaled</strong></td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Autoscale &gt; Channels (All Channels, Only Displayed Channels)</td>
</tr>
<tr>
<td><strong>Acquisition mode during autoscale</strong></td>
<td>[Utility] &gt; Options &gt; Preferences &gt; Autoscale &gt; Acq Mode (Use normal acquisition mode, Preserve acquisition mode)</td>
</tr>
<tr>
<td><strong>Oscilloscope clock</strong></td>
<td>[Utility] &gt; Options &gt; Clock &gt;</td>
</tr>
<tr>
<td><strong>Softkey menu timeout</strong></td>
<td>[Utility] &gt; Options &gt; Menu Timeout</td>
</tr>
</tbody>
</table>
USB Storage Devices

Use your PC to create directories on a USB storage device.

Most USB mass storage devices are compatible with the oscilloscope. However, certain devices may be incompatible, and may not be able to be read or written to. USB storage devices must be formatted with the FAT or FAT32 file system format.
When the USB mass storage device is connected to the oscilloscope's USB host port, a small four-color circle icon may be displayed briefly as the USB device is read.

You do not need to "eject" the USB mass storage device before removing it. Simply ensure that any file operation you've initiated is done, and remove the USB drive from the oscilloscope's host port.

Do not connect USB devices that identify themselves as hardware type "CD" because these devices are not compatible with the InfiniiVision X-Series oscilloscopes.

Configuring the [Quick Action] Key

The [Quick Action] key lets you perform common, repetitive actions by pressing a single key.

Table 33 Quick Action Features

<table>
<thead>
<tr>
<th>Feature</th>
<th>Front Panel Key/Softkey Location (see built-in help for more information)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quick action setup</td>
<td>[Utility] &gt; Quick Action &gt; Action,</td>
</tr>
<tr>
<td></td>
<td>• Off</td>
</tr>
<tr>
<td></td>
<td>• Quick Measure All</td>
</tr>
<tr>
<td></td>
<td>• Quick Mask Statistics Reset – see &quot;Mask Testing&quot; on page 65.</td>
</tr>
<tr>
<td></td>
<td>• Quick Print – see &quot;Print (Screens)&quot; on page 85.</td>
</tr>
<tr>
<td></td>
<td>• Quick Save – see &quot;Save/Recall (Setups, Screens, Data)&quot; on page 82.</td>
</tr>
<tr>
<td></td>
<td>• Quick Recall</td>
</tr>
<tr>
<td></td>
<td>• Quick Freeze Display</td>
</tr>
<tr>
<td></td>
<td>• Quick Trigger Mode – see &quot;Trigger Mode, Coupling, Reject, Holdoff&quot; on page 51.</td>
</tr>
<tr>
<td></td>
<td>• Quick Clear Display</td>
</tr>
<tr>
<td>Quick action perform</td>
<td>[Quick Action]</td>
</tr>
</tbody>
</table>
Specifications and Characteristics

For up-to-date specifications and characteristics on the 1000 X-Series oscilloscopes, see the data sheet at: www.keysight.com/find/1000X-Series
# Environmental Conditions

<table>
<thead>
<tr>
<th>Environment</th>
<th>Indoor use only.</th>
</tr>
</thead>
</table>
| **Ambient temperature** | Operating: 0 °C to +50 °C  
                          Non-operating: -40 °C to +70 °C |
| **Humidity**         | Operating: Up to 95% RH, non-condensing to temperatures up to +40 °C decreasing linearly to 50% RH at +50 °C  
                          Non-operating: Up to 90% RH up to +65 °C (non condensing) |
| **Altitude**         | Operating: to 3,000 m  
                          Non-operating to 15,300 m |
| **Overvoltage Category** | This product is intended to be powered by MAINS that comply to Overvoltage Category II, which is typical of cord-and-plug connected equipment. |
| **Pollution Degree** | The InfiniiVision 1000 X-Series oscilloscopes may be operated in environments of Pollution Degree 2 (or Pollution Degree 1). |

### Pollution Degree Definitions

- **Pollution Degree 1**: No pollution or only dry, non-conductive pollution occurs. The pollution has no influence. Example: A clean room or climate controlled office environment.
- **Pollution Degree 2**: Normally only dry non-conductive pollution occurs. Occasionally a temporary conductivity caused by condensation may occur. Example: General indoor environment.
- **Pollution Degree 3**: Conductive pollution occurs, or dry, non-conductive pollution occurs which becomes conductive due to condensation which is expected. Example: Sheltered outdoor environment.

---

# Declaration of Conformity

For Declarations of Conformity for Keysight products, go to:

[www.keysight.com/go/conformity](http://www.keysight.com/go/conformity)
Probes and Accessories

For a list of the probes and accessories that are compatible with the 1000 X-Series oscilloscopes, see the data sheet at: www.keysight.com/find/1000X-Series

Because the 1000 X-Series oscilloscopes do not have a ring around the BNC connector for identifying probes, you must set the probe attenuation factor manually. See "Setting Analog Channel Probe Options" on page 38.

See Also

For more information on probes and accessories, see www.keysight.com for:

- Probes and Accessories Selection Guide (5989-6162EN)
- InfiniiVision Oscilloscope Probes and Accessories Selection Guide Data Sheet (5968-8153EN)
- For compatibility information, manuals, application notes, data sheets, selection guides, SPICE models, and more for oscilloscope probes, see the Probe Resource Center at: www.keysight.com/find/PRC
Software and Firmware Updates

From time to time Keysight Technologies releases software and firmware updates for its products. To search for firmware updates for your oscilloscope, direct your web browser to www.keysight.com/find/1000X-Series-sw.

To view the currently installed software and firmware press [Help] > About Oscilloscope.

Once you have downloaded a firmware update file, you can place it on a USB storage device and load the file using File Explorer (see "Utility Settings" on page 86).
# Acknowledgements

## Table 34 Third Party Software

<table>
<thead>
<tr>
<th>Software</th>
<th>Description and Copyright</th>
<th>License¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>7-zip</td>
<td>Copyright (C) 1999-2016 Igor Pavlov.</td>
<td>GNU LGPL + unRAR restriction</td>
</tr>
<tr>
<td>Boost Libraries</td>
<td>Copyright © 2008 Beman Dawes, Rene Rivera</td>
<td>Boost Software License (BSL-1.0)</td>
</tr>
<tr>
<td>HDF5</td>
<td>HDF5 was developed by The HDF Group and by the National Center for Supercomputing Applications at the University of Illinois at Urbana-Champaign. Copyright 2006-2016 by The HDF Group. Copyright 1998-2006 by the Board of Trustees of the University of Illinois.</td>
<td>BSD-style open source</td>
</tr>
<tr>
<td>libmspack</td>
<td>Copyright: © 2003-2013 Stuart Caie Source code can be obtained from the third party or by contacting Keysight. Keysight will charge for the cost of physically performing the source distribution.</td>
<td>Lesser or Library General Public License version 3.0 (LGPLv3)</td>
</tr>
<tr>
<td>libpng</td>
<td>Copyright (c) 1998-2002,2004,2006-2016 Glenn Randers-Pehrson (Version 0.96 Copyright (c) 1996, 1997 Andreas Dilger) (Version 0.88 Copyright (c) 1995, 1996 Guy Eric Schalnat, Group 42, Inc.)</td>
<td>libpng specific</td>
</tr>
<tr>
<td>OpenNETCF Smart Device Framework</td>
<td>Copyright (c) 2001-2014 Tacke Consulting, LLC</td>
<td>MIT License</td>
</tr>
<tr>
<td>TCLAP</td>
<td>Copyright (c) 2003 Michael E. Smoot</td>
<td>MIT License</td>
</tr>
<tr>
<td>time_ce</td>
<td>Copyright (C) 2002 Michael Ringgaard. All rights reserved.</td>
<td>MIT License</td>
</tr>
<tr>
<td>U-Boot</td>
<td>(C) Copyright 2000 - 2013 Wolfgang Denk, DENX Software Engineering, <a href="mailto:wd@denx.de">wd@denx.de</a>. Source code can be obtained from the third party or by contacting Keysight. Keysight will charge for the cost of physically performing the source distribution.</td>
<td>GNU General Public License (GPL or GPLv2)</td>
</tr>
</tbody>
</table>
### Table 34  Third Party Software (continued)

<table>
<thead>
<tr>
<th>Software</th>
<th>Description and Copyright</th>
<th>License¹</th>
</tr>
</thead>
<tbody>
<tr>
<td>WCELIBCEX</td>
<td>File copyright is held by a file author. Files created for the first version of the WCELIBCEX project are copyrighted by (c) 2006 Taxus SI Ltd., <a href="http://www.taxussi.com.pl">http://www.taxussi.com.pl</a> See comment in header of source files for more details.</td>
<td>MIT License</td>
</tr>
<tr>
<td>zlib</td>
<td>Copyright (C) 1995-2013 Jean-loup Gailly and Mark Adler</td>
<td>zlib license</td>
</tr>
</tbody>
</table>

¹These licenses are located on the Keysight InfiniiVision oscilloscopes manuals website at www.keysight.com/find/1000X-Series-manual.
Product Markings and Regulatory Information

These symbols are used on the 1000 X-Series oscilloscopes.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Caution, risk of electric shock" /></td>
<td>Caution, risk of electric shock</td>
</tr>
<tr>
<td><img src="image" alt="Caution, refer to accompanying documentation" /></td>
<td>Caution, refer to accompanying documentation</td>
</tr>
<tr>
<td><img src="image" alt="This symbol indicates separate collection for electrical and electronic equipment mandated under EU law as of August 13, 2005. All electric and electronic equipment are required to be separated from normal waste for disposal (Reference WEEE Directive 2002/96/EC)." /></td>
<td>This symbol indicates separate collection for electrical and electronic equipment mandated under EU law as of August 13, 2005. All electric and electronic equipment are required to be separated from normal waste for disposal (Reference WEEE Directive 2002/96/EC).</td>
</tr>
<tr>
<td><img src="image" alt="Indicates the time period during which no hazardous or toxic substance elements are expected to leak or deteriorate during normal use. Forty years is the expected useful life of the product." /></td>
<td>Indicates the time period during which no hazardous or toxic substance elements are expected to leak or deteriorate during normal use. Forty years is the expected useful life of the product.</td>
</tr>
<tr>
<td><img src="image" alt="The RCM mark is a registered trademark of the Australian Communications and Media Authority." /></td>
<td>The RCM mark is a registered trademark of the Australian Communications and Media Authority.</td>
</tr>
<tr>
<td><img src="image" alt="The CE mark is a registered trademark of the European Community. ICES / NMB-001 Cet appareil ISM est conforme a la norme NMB du Canada. This is a marking to indicate product compliance with the Industry Canadian Interference-Causing Equipment Standard (ICES-001). This is also a symbol of an Industrial Scientific and Medical Group 1 Class A product (CISPR 11, Clause 4)." /></td>
<td>The CE mark is a registered trademark of the European Community. ICES / NMB-001 Cet appareil ISM est conforme a la norme NMB du Canada. This is a marking to indicate product compliance with the Industry Canadian Interference-Causing Equipment Standard (ICES-001). This is also a symbol of an Industrial Scientific and Medical Group 1 Class A product (CISPR 11, Clause 4).</td>
</tr>
<tr>
<td><img src="image" alt="The CSA mark is a registered trademark of the CSA International." /></td>
<td>The CSA mark is a registered trademark of the CSA International.</td>
</tr>
<tr>
<td><img src="image" alt="South Korean Certification (KC) mark; includes the marking's identifier code which follows this format: MSIP-REM-YYY-ZZZZZZZZZZZ" /></td>
<td>South Korean Certification (KC) mark; includes the marking's identifier code which follows this format: MSIP-REM-YYY-ZZZZZZZZZZZ.</td>
</tr>
</tbody>
</table>
Symbols

(-) Width measurement, 64
(+) Width measurement, 64

Numerics

10-bit write trigger, I2C, 78

A

About Oscilloscope, 87
AC channel coupling, 37
AC RMS measurement, 64
accessories, 12, 91
acquire, 54
Acquire key, 21, 33, 34
Acquisition controls, 21
acquisition memory, saving, 83
acquisition mode, 54
acquisition mode during autoscale, 86
acquisition mode, preserve during AutoScale, 86
autoscale preferences, 86
autoscale, undo, 17, 86
Average measurement, 64
averaging acquisition mode, 54

B

Back key, 20
bandwidth, 20
bandwidth limit, 37
bandwidth required, oscilloscope, 59
bandwidth, oscilloscope, 56
Base measurement, 64
base, UART/RS232, 81
baud rate, CAN, 77
baud rate, LIN, 79
boud rate, UART/RS232, 81
BIN file format, 83
bit order, SPI, 80
bit order, UART/RS232, 81
Blackman Harris FFT window, 40, 44
blanking, 34
BMP file format, 82
Bode plot, frequency response analysis, 73
brick-wall frequency response, 56
brightness of waveforms, 20

C

calibration, 87
calibration protect button, 26
CAN baud rate, 77
CAN bus trigger, 78
CAN counters, 77
CAN polarity, 77
CAN sample point, 77
CAN serial bus decode/trigger, 77
CAN signal setup, 77
cascaded math functions, 44
Center, FFT, 40
Center, FFT (Magnitude), FFT (Phase), 44
clear display, 47
clear display, Quick Clear Display, 88
Clear measurements, 64
clear persistence, 47
clear, mask test, 65
clock, oscilloscope, 86
color printing, 85
color screen image, 82
compensate passive probes, 18, 24
Conformity, Declaration of, 90
built-in help, 29
bus configuration, UART/RS232, 80
Bus key, 23, 39, 76
buttons (keys), front panel, 20
connectors, rear panel, 26
control, remote, 86
controls, front panel, 20
copyright, 2
Counter measurement, 64
counters, CAN, 77
counters, UART/RS232, 81
coupling, channel, 37
coupling, trigger, 52
crosstalk between input channels, 36
crosstalk problems, 40
CSV file format, 83
cursor measurements, 61
cursors, binary, 62
cursors, hex, 62
cursors, manual, 62
cursors, track waveform, 62
cutoff frequency, low-pass filter, 45

cross section, 98

damage, shipping, 12
data sheet, 89
date, 86
DC channel coupling, 37
DC RMS measurement, 64
DC signals, checking, 52
DC waveform generator output, 75
decibels, FFT (Magnitude) vertical units, 45
decibels, FFT vertical units, 40
decimating samples, 60
Declaration of Conformity, 90
decode, CAN serial bus, 77
decode, I2C serial bus, 78
decode, LIN serial bus, 78
decode, SPI serial bus, 79
decode, UART/RS232 serial bus, 80
default configuration, 16
default label library, 47
default setup, 16
Default Setup key, 21
defaults, waveform generator, 75
degrees, FFT (Phase) vertical units, 45
Delay measurement, 64
delay time, 34
delete file, 86
Demo terminal, 24
digital voltmeter (DVM), 72
digital voltmeter mode, 72
Display key, 22
display multiple acquisitions, 32
display, area, 27
display, interpreting, 27
display, persistence, 47
display, softkey labels, 28
display, status line, 27
displayed channels AutoScale, 86
distortion problems, 40
Divide math function, 44
Duty cycle measurement, 64
DVM (digital voltmeter), 72

decibels, FFT (Phase) zero phase reference, 45
Entry knob, 21
Entry knob, push to select, 21
environmental conditions, 90
erase, secure, 83
error action, mask test, 65
expand about, 24, 86
expand about center, 86
expand about ground, 86
exporting waveform, 82
Ext Trig as Z-axis input, 34
Ext Trig input connector, 23
External key, 23
external memory device, 25
external trigger, 53
external trigger waveform, position, 53
external trigger, input impedance, 53
external trigger, probe attenuation, 53
external trigger, probe units, 53
external trigger, range, 53
external trigger, threshold, 53

F
factory default settings, 83
Fall time measurement, 64
fast debug AutoScale, 86
FAT file system format, 87
FAT32 file system format, 87
FFT (Magnitude), FFT (Phase) vertical units, 45
FFT aliasing, 42
FFT DC value, 42
FFT key, 23
FFT magnitude math function, 44
FFT measurement hints, 40
FFT phase math function, 44
FFT resolution, 41
FFT spectral analysis, 40
FFT spectral leakage, 43
FFT vertical units, 40
FFT window, 40
file explorer, 86
file format, ASCII, 83
file format, BIN, 83
file format, BMP, 82
file format, CSV, 83
file format, PNG, 82
file, save, recall, load, 86
filter, low pass, 44
fine adjustment, vertical scale, 37
firmware updates, 92
flash drive, 25
Flat top FFT window, 40, 44
FM (frequency modulation), waveform generator output, 75
folding frequency, 55
Force key, 23
forcing a trigger, 52
FRA (frequency response analysis), 73
frame trigger, 12C, 78
framing, SPI, 80
framing, UART/RS232, 81
freeze display, 48, 88
freeze display, Quick Freeze Display, 88
Frequency measurement, 64
frequency modulation (FM), waveform generator output, 75
frequency requirements, power source, 13
frequency response analysis (FRA), 73
frequency response analysis data, save, 74
Index

N
navigate files, 86
noise rejection, 52
noise waveform generator output, 75
noise, adding to waveform generator output, 75
noise, high-frequency, 52
noise, low-frequency, 52
noisy signals, 51
non-volatile memory, secure erase, 83
normal acquisition mode, 54
Normal trigger mode, 52
notices, 2
number of bits, UART/RS232, 80
Nyquist frequency, 42
Nyquist sampling theory, 55
operators, math, 44
options, print, 85
oscilloscope bandwidth, 56
oscilloscope bandwidth required, 59
oscilloscope clock, 86
oscilloscope rise time, 58
oscilloscope sample rate, 58
output load expected, waveform generator, 75
output, Gen Out, 87
overdrive on input channels, avoiding, 36
overlay, localized, 25
Overshoot measurement, 64
overvoltage category, 90

P
parity, UART/RS232, 81
passive probes, compensating, 18
pattern trigger, 51
peak detect acquisition mode, 54
Peak-peak measurement, 64
Period measurement, 64
persistance, clearing, 47
persistance, infinite, 32
Phase measurement, 64
Phase plot in FRA chart, 73
phase X cursor units, 62
PNG file format, 82
points per decade, FRA, 73
polarity, CAN, 77
polarity, UART/RS232, 81
pollution degree, 90
pollution degree, definitions, 90
position, external trigger waveform, 53
post-processing, 63
power consumption, 13
power cord connector, 26
power requirements, 13
power supply, 26
power switch, 13, 20
power-on, 13
print, 88
print options, 85
print, landscape, 85
print, Quick Print, 88
printer selection, 85
printer, USB, 25, 85
printing the display, 85
probe attenuation, 38
probe check, 38
probe compensation, 24
probe compensation, 10:1 setting required, 18
probe options, 38
probe units, 38
probes, 91
probes, connecting to oscilloscope, 14
probes, passive, compensating, 18
protect, user calibration, 87
pulse waveform generator output, 75
pulse width trigger, 51
Quick Action key, 22, 88
Quick Clear Display, 88
Quick Freeze Display, 88
Quick Help, 29
Quick Help language, 29
Quick Mask Statistics Reset, 88
Quick Measure All, 88
Quick Print, 88
Quick Print quick action, 85
Quick Recall, 88
Quick Save, 88
quick save to USB storage device, 83
Quick Trigger Mode, 88

R
radians, FFT (Phase) vertical units, 45
ramp waveform generator output, 75
random noise, 51
range, external trigger, 53
ratio X cursor units, 62
ratio Y cursor units, 62
raw acquisition record, 83
rear panel connectors, 26
re-arm time, segmented memory, 55
recall, 88
call, Quick Recall, 88
rectangular FFT window, 40, 44
Ref key, 23, 46
reference waveforms, 46
reference, vertical expansion, 86
regulatory information, 95
remote control, 86
required oscilloscope bandwidth, 59
restart condition, I2C trigger, 78
rise time measurement, 64
rise time, oscilloscope, 58
rise time, signal, 59
rise/fall edge transition time trigger, 51
roll time mode, 34
RS232/UART serial bus decode/trigger, 80
run acquisitions, 32
Run Control keys, 22
run until, mask test, 65

S
safety warning, 14
sample point, CAN, 77
sample point, LIN, 79
sample rate, 3
sample rate and memory depth, 59
sample rate, oscilloscope, 56, 58
sampling theory, 55
sampling, overview, 55
save, 88
save file, 86
save segment, 55
save setup files, 82
save times, data, 83
Save to USB key, 22, 83
save, Quick Save, 88
Save/Recall key, 22
saver, screen, 86
saving data, 82
screen image, saving, 22
screen saver, 86
segments, 55
segmented memory acquisitions, 55
segmented memory, re-arm time, 87
segmented memory, saving
segmented memory navigation, 55
segmented memory, saving segments, 55
selecting, values, 21
self test, front panel, 87
self test, hardware, 87
serial bus decode/trigger, 76
serial bus trigger, 51, 77
serial decode controls, 23
serial decode, CAN, 77
serial decode, I2C, 78
serial decode, LIN, 78
serial decode, SPI, 79
serial decode, UART/RS232, 80
serial number, 87
service functions, 87
setup and hold violation trigger, 51
setup files, saving, 82
setup, default, 16
setups, recall, 83
shipping damage, 12
show parity, LIN, 79
Sigma, minimum, 65
signal setup, CAN, 77
signal setup, I2C, 78
signal setup, LIN, 79
signal setup, SPI, 80
signal setup, UART/RS232, 80
sine waveform generator output, 75
sine waveforms, 38
Single key, 32
single-shot acquisitions, 52
skew, analog channel, 38
slope trigger, 51
Snapshot All measurements, 64
snapshot all, quick action, 88
softkey labels, 28
softkeys, 6, 20
software updates, 92
software version, 87
source lock, mask test, 65
Span, FFT, 40
Span, FFT (Magnitude), FFT (Phase), 44
specifications, 89
spectral analysis, FFT, 40
spectral leakage, FFT, 43
SPI bit order, 80
SPI bus trigger, 80
SPI framing, 80
SPI serial bus decode/trigger, 79
SPI signal setup, 80
SPI word size, 80
square waveform generator output, 75
square waves, 57
standard, LIN, 79
start acquisition, 22
start condition, I2C, 78
statistics, mask test, 65
status line, 27
status, User Cal, 87
stop acquisition, 22
stop acquisitions, 32
stop condition, I2C, 78
subtract math function, 44
sweep frequencies, frequency response analysis, 73
sync break, LIN, 79
sync pulse, waveform generator, 75
T
temperature (environmental conditions), 90
template, front panel, 25
test, mask, 65
time, 23, 50
threshold, analog channel measurements, 64
threshold, external trigger, 53
turn channel on, 24

U
UART/RS232 base, 81
UART/RS232 baud rate, 81
UART/RS232 bit order, 81
UART/RS232 bus configuration, 80
UART/RS232 counters, 81
UART/RS232 framing, 81
UART/RS232 number of bits, 80
UART/RS232 parity, 81
UART/RS232 polarity, 81
UART/RS232 serial bus decode/trigger, 80
UART/RS232 signal setup, 80
UART/RS232 trigger, 81
under-sampled signals, 55
units, cursor, 62
units, external trigger probe, 53
units, math, 45
units, probe, 38
updating software and firmware, 92
USB device port, remote control, 26, 86
USB host port, 25, 85
USB printer, 85
USB printers, supported, 85
USB storage device, 25
USB, CD device, 88
USB, eject device, 25
user cal, 87
user calibration, 87
user calibration protect, 87
user interface language, 29, 87
Utility key, 22
utility settings, 86

V
V RMS, FFT (Magnitude) vertical units, 45
V RMS, FFT vertical units, 40
values, choosing, 21
variable persistence, 47
ventilation requirements, 13
vernier, channel, 24
Vertical controls, 24, 36
vertical expansion, 24
vertical expansion reference, 86
Vertical knobs and keys, 36
vertical position knobs, 24
vertical scale fine adjustment, 37
vertical scale knobs, 24
vertical sensitivity, 24
Vertical softkey controls, 36
Vertical Units, FFT, 40
Vertical Units, FFT (Magnitude), FFT (Phase), 45
video trigger, 51
Volt units, 38, 53
voltage measurements, 64

W
warranted specifications, 89
warranty, 2
Wave Gen key, 23, 24
waveform data, saving, 83
waveform generator, 75
waveform generator amplitude, frequency response analysis, 73
waveform generator defaults, restoring, 75
waveform generator expected output load, 75
waveform generator logic presets, 75
waveform generator output, Gen Out signal, 87
waveform generator sync pulse, 75
waveform generator, waveform type, 75
Waveform keys, 23
waveform type, waveform generator, 75
waveform, cursor tracking, 62
waveform, intensity, 47
waveform, saving/exporting, 82
white noise, adding to waveform generator output, 75
Width - measurement, 64
Width + measurement, 64
Window, FFT, 40
window, FFT (Magnitude), FFT (Phase), 44
word size, SPI, 80

X
XY time mode, 34

Z
Z-axis blanking, 34
zero phase reference, FFT (Phase), 45